Bug 1008907 - systemd-207-2 kills gfx sessions
systemd-207-2 kills gfx sessions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
: 1009374 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 06:25 EDT by Nicolas Mailhot
Modified: 2013-09-22 20:38 EDT (History)
10 users (show)

See Also:
Fixed In Version: systemd-207-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-22 20:38:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-09-17 06:25:43 EDT
Description of problem:
systemd-207-2 kills gfx sessions (no gdm, fail whale on startx)

downgrading to systemd-207-1 restores working gdm

is there a way to tell gnome 3 I don't want to see the fail whale one time more and a term is more useful than this POS ?
Comment 1 Yanko Kaneti 2013-09-17 07:11:14 EDT
FWIW its
Patch0023: 0023-Verify-validity-of-session-name-when-received-from-o.patch
thats breaking it.
Comment 2 Zbigniew Jędrzejewski-Szmek 2013-09-17 10:16:06 EDT
Fix is upstream in 35375af login: fix login_is_valid test.
Comment 3 Fedora Update System 2013-09-17 13:08:04 EDT
systemd-207-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/systemd-207-3.fc20
Comment 4 Fedora Update System 2013-09-17 14:16:18 EDT
Package systemd-207-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-207-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16966/systemd-207-3.fc20
then log in and leave karma (feedback).
Comment 5 Zbigniew Jędrzejewski-Szmek 2013-09-18 08:39:53 EDT
*** Bug 1009374 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-09-22 20:38:53 EDT
systemd-207-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.