Bug 1008918 - Only 1 process shown for 2 versions of deployment
Only 1 process shown for 2 versions of deployment
Status: CLOSED DUPLICATE of bug 1167610
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mauricio Salatino
Pavel Kralik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 06:39 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-26 03:02:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-09-17 06:39:34 EDT
Description of problem:
Imagine you have a project A with version 1. In this project, you have a process P. You deploy this project. Then you need to do some changes and deploy an updated version of the project, version 2. But for some reason, you cannot undeploy the first version - perhaps some instances of process P are still running. You just deploy the new version, successfully.
Now, in the Deployments, you can see the two version deployed at the same time. But you can only see one process P in the Process Definitions perspective. 

These two processes might be different, they are definitely from different deployments, so they should be both displayed.

Same thing happens if you also change the process version before the new deployment.

Only the old version of the process is available. If you remove the older deployment, the older process also disappears, of course, but the new version still isn't available, even after refreshing.


Version-Release number of selected component (if applicable):
BPMS 6.0 ER3


Steps to Reproduce:
1. Create project A, set version 1.
2. Create process P, set version to 1, in project A.
3. Save the process and build and deploy the project.
4. Check the Deployments and Process Definitions for the project and process.
5. Go back to Authoring and change the process version to 2, save it.
6. Change to project version to 2, save, build and deploy.
7. Check the Deployments - the project v.2 is there as well.
8. Go to Process Definitions.
9. Go to Deployments, remove deployment of project A, version 1. Repeat step 8.


Actual results:
8. There is only process P, version 1  available.
9. There is no process P, none of the versions are available.


Expected results:
8. There should be two versions of process P available - 1 and 2.
9. Only one v.2 of process P is available.
Comment 1 Maciej Swiderski 2013-09-23 09:26:17 EDT
Zuzana, I just tried with both ER3 and master(community) and was not able to reproduce the described behavior. Would you mind to check it once again on your end that the right deployments were removed. Maybe a good idea would be to have a hangout quickly where you could show me how to reproduce it. Maybe I am missing something here...
Comment 2 Zuzana Krejčová 2013-09-24 04:59:25 EDT
(In reply to Maciej Swiderski from comment #1)
> Zuzana, I just tried with both ER3 and master(community) and was not able to
> reproduce the described behavior. Would you mind to check it once again on
> your end that the right deployments were removed. Maybe a good idea would be
> to have a hangout quickly where you could show me how to reproduce it. Maybe
> I am missing something here...

Well. I've reproduced this again. Then started recording another attempt, so that I'd have a short .mpeg for you at least and since then I am unable to reproduce this as well.

The only cause for this that seems at least a bit probable is linked with bug 983585 comment 4 - I used save, not autosave, and I'm quite sure the changes got saved, that I got the green message about successful save, but.. who knows.

When I tried with no changes made to the process, the results were the same as in this bug. So, if you have 2 deployments with the same process (name, id, version), only one of them is shown in the Process Definitions. Not sure if this is ok. If it is, perhaps we can close this issue and I'll focus on the Designer - whether there is some intermittent problem with 'Save'.
Comment 3 Maciej Swiderski 2013-09-24 05:34:41 EDT
I would say then it behaves as expected as we have only process name, id and version as elements that the UI considers and that causes they are not visible - or only one is visible. If we would included another column e.g deployment id then both should be visible. Not sure that we should add another column for that. Most likely different deployments will have independent process id, etc.

So my vote is to close this one unless we decide that the current behavior shall be altered.
Comment 4 Kris Verlaenen 2013-12-09 20:02:56 EST
From Prakash: 
At this point we should move forward with what exists (option 1) with mouse over note that may highlight the difference, I would not be comfortable adding the ids to the table at this point.  We need to think through this properly and come up with something that is intuitive to the user.  We can tackle that for post 6.0.
Comment 7 Maciej Swiderski 2014-11-25 13:49:31 EST
I believe this can be either marked as modified or as duplicate - see https://bugzilla.redhat.com/show_bug.cgi?id=1167610 that is marked as modified.
Comment 8 Zuzana Krejčová 2014-11-26 03:02:48 EST

*** This bug has been marked as a duplicate of bug 1167610 ***

Note You need to log in before you can comment on or make changes to this bug.