Bug 100894 - confirm and graphical boot together cause problems
Summary: confirm and graphical boot together cause problems
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-26 21:32 UTC by Jay Berkenbilt
Modified: 2014-03-17 02:37 UTC (History)
4 users (show)

Fixed In Version: 7.41-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 19:59:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Berkenbilt 2003-07-26 21:32:17 UTC
Description of problem:

If you have GRAHPICAL boot enabled and boot into runlevel 5 with "confirm" on
the commandline, the boot hangs once the graphical boot starts.

Version-Release number of selected component (if applicable):

9.0.93, initscripts 7.28-1

How reproducible:

always, I assume...

Steps to Reproduce:
1. with GRAHPICAL=yes in /etc/sysconfig/init, boot into runlevel 5 appending
"confirm" to kernel comandline

Actual results:

Graphical boot starts and then fails to make progress.

Expected results:

I would expect "confirm" to automatically apply "nogui".  It seems to me that
this would be an easy fix.  I think this is better than disregarding confirm
since a commandline argument should always take precedence over a configuration
file, and I think it's silly to have to type both confirm and nogui.

Additional info:

I had already added DontZap to my XF86Config file, so I don't know whether
CTRL-ALT-Backspace would have shut down the X server that was showing the
graphical bootup status since I know it wouldn't work for my configuration.

Comment 1 Bill Nottingham 2003-10-22 19:59:22 UTC
Will be fixed in initscripts-7.41-1, in combination with rhgb-0.11 or later.


Note You need to log in before you can comment on or make changes to this bug.