Bug 1008986 - [User Portal] Bogus console type on Windows client, probably impacting auto-connect
[User Portal] Bogus console type on Windows client, probably impacting auto-c...
Status: CLOSED DUPLICATE of bug 998705
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Frantisek Kobzik
Pavel Stehlik
virt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 08:46 EDT by Jiri Belka
Modified: 2013-09-23 07:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 07:29:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
w7 64bit ie9 User portal (127.50 KB, image/png)
2013-09-17 08:46 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-09-17 08:46:07 EDT
Created attachment 798802 [details]
w7 64bit ie9 User portal

Description of problem:
When I logged from Windows 7 64bit client IE9 to User Portal while having one assigned and started VM, I see next to 'Console:' no console type, just 'Edit'.

Inside Console Options dialog I see completely bogus settings - RDP is selected but it is gray with tooltip "RDP isn't available for this machine.". So why is that selected if it is not available? :-) Then under 'RDP Options' there are no options... See screenshot. Sometimes I cannot even open Console Options dialog, do F5 to reload the page, then clicking on Edit works.

I suppose this bug affects BZ1008935.

Version-Release number of selected component (if applicable):
is15 - windows 7 64bit IE9

How reproducible:
100%

Steps to Reproduce:
1. clean IE, login to User Portal _without_ autoconnect to get spice plugin
2. log out
3. login with autoconnect
4. check Console Options dialog

Actual results:
console options sometimes cannot be opened (F5) and then the dialog has bogus settings which make no sense (to me at least)

Expected results:
right after login there should be visible console type, edit to open console options must work and settings in the dialog has to make sense and be valid to reality

Additional info:
Comment 1 Michal Skrivanek 2013-09-19 08:07:26 EDT
once bug 1008935 is solved then this is probably only cosmetic or nonexistant, but rather keep it open till then...
Comment 3 Frantisek Kobzik 2013-09-23 07:29:39 EDT

*** This bug has been marked as a duplicate of bug 998705 ***

Note You need to log in before you can comment on or make changes to this bug.