Bug 998705 - When selecting an active VM the console button is not enabled immediately
When selecting an active VM the console button is not enabled immediately
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Frantisek Kobzik
Lukas Svaty
virt
:
: 1008935 1008986 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 16:05 EDT by Alexander Wels
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version: is16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:14:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19137 None None None Never

  None (edit)
Description Alexander Wels 2013-08-19 16:05:44 EDT
Description of problem:
The console button does not become active immediately when selecting an active VM.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Have a running VM in the VM list.
2. Click on the row in the grid to select the VM.
3. Look at the console button, it is still grayed out for a couple of seconds. After a few seconds it becomes enabled.

Actual results:


Expected results:
The console button becomes enabled immediately when selecting a row.


Additional info:
Comment 1 Frantisek Kobzik 2013-09-10 10:45:59 EDT
This bug is was introduced by adding some async calls into selected protocol detection. This async call takes some time, meanwhile the updateActionAvailability finishes and sets console availability to false. This is more of a design issue (updateActionAvailibility is periodical). I'll take a look at it to see if can be worked-around.
Comment 2 Frantisek Kobzik 2013-09-18 09:20:54 EDT
merged u/s: 54da2f7f31a87b6f36b32d0a39e3d793bc75ace5
Comment 3 Frantisek Kobzik 2013-09-23 07:22:42 EDT
*** Bug 1008935 has been marked as a duplicate of this bug. ***
Comment 4 Michal Skrivanek 2013-09-23 07:28:51 EDT
as this is a root cause of bug 1008935, moving this to 3.3
Comment 5 Frantisek Kobzik 2013-09-23 07:29:39 EDT
*** Bug 1008986 has been marked as a duplicate of this bug. ***
Comment 6 Lukas Svaty 2013-09-27 08:50:15 EDT
tested in is16
Comment 7 Itamar Heim 2014-01-21 17:14:18 EST
Closing - RHEV 3.3 Released
Comment 8 Itamar Heim 2014-01-21 17:22:03 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.