Bug 100904 - package requires Tk fails in tclsh
package requires Tk fails in tclsh
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tcltk (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Bill Huang
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-26 18:21 EDT by Joel
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 03:15:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joel 2003-07-26 18:21:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030703 Galeon/1.3.7

Description of problem:
There is a mis-build with tcl for finding TK.  This 
becomes manifest with i8kmon in the i8kutils (freshrpms).

According to the i8kmon man page:

On some Linux distributions i8kmon exits with an error like this:
                                                                               
                                                            
              can�t find package Tk
                  while executing
              "package require Tk"
 
This is not a bug in  i8kmon.  It  means  that  Tcl/Tk  files  are  not
installed  correctly on your system and the Tk library can�t be dynamically
loaded from Tcl. In this case you can run i8kmon  with  the command:
 
              wish /usr/bin/i8kmon -- [options...]
 
and in the readme from debian:

You should also report the bug to the maintainer of the Tcl/Tk package
included in your Linux distribution. A quick fix for the problem could
also be adding the following line to /usr/lib/tk8.3/pkgIndex.tcl:

    package ifneeded Tk 8.3 [list load "/usr/lib/libtk8.3.so.1" Tk]


Version-Release number of selected component (if applicable):
8.3.5 90.1

How reproducible:
Always

Steps to Reproduce:
1. type i8kmon
2.
3.
    

Actual Results:  $ i8kmon
can't find package Tk
    while executing
"package require Tk"
    (procedure "make_ui" line 15)
    invoked from within
"make_ui"
    (procedure "main" line 4)
    invoked from within
"main"
    invoked from within
"if {$tcl_interactive == 0} {
    main
    vwait exit
}"
    (file "/usr/bin/i8kmon" line 670)


Expected Results:  program runs

Additional info:
Comment 1 Jens Petersen 2003-08-09 23:33:24 EDT
It sounds reasonable enough, except tk-8.3.5 doesn't seem to come with
pkgIndex.tcl file afaict.
Comment 2 Jens Petersen 2003-11-28 07:51:04 EST
Fixed in the new tcl and tk 8.4 package just built.

Note You need to log in before you can comment on or make changes to this bug.