Bug 1009057 - Cannot set VM console to VNC when "Single PCI" was selected beforehand
Cannot set VM console to VNC when "Single PCI" was selected beforehand
Status: CLOSED DUPLICATE of bug 1009391
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michal Skrivanek
Pavel Stehlik
virt
:
Depends On:
Blocks: 1000039
  Show dependency treegraph
 
Reported: 2013-09-17 10:58 EDT by Pavel Novotny
Modified: 2013-10-02 09:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 09:35:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot: VM pop-up window with error message. (82.53 KB, image/png)
2013-09-17 11:01 EDT, Pavel Novotny
no flags Details

  None (edit)
Description Pavel Novotny 2013-09-17 10:58:19 EDT
Description of problem:
Cannot create nor update VM, where the "Single PCI" check box is checked first and the console type is then switched to VNC.

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.22.master.el6ev.noarch (is15)

How reproducible:
100%

Steps to Reproduce:
1. Open `Create VM` or `Edit VM` dialog, set the mandatory VM name.
2. On `Console` tab, make sure the console type is set to SPICE and `Single PCI` is checked.
3. Then change console type to VNC and submit.

Actual results:
Cannot add/edit VM. Cannot set single display device via VNC display.

Expected results:
`Single PCI` shoud be automatically turned off when the console type is not SPICE. The VM should be created/updated successfully.

Additional info:

A good use case where this can happen is to try to create a VM with Linux-based OS (where Single PCI is enabled by default) and just switch console type to VNC.
Comment 1 Pavel Novotny 2013-09-17 11:01:54 EDT
Created attachment 798856 [details]
Screenshot: VM pop-up window with error message.
Comment 2 Michal Skrivanek 2013-10-02 09:35:37 EDT
no need to track separately. work in progress in bug 1009391

*** This bug has been marked as a duplicate of bug 1009391 ***

Note You need to log in before you can comment on or make changes to this bug.