Bug 1009391 - Change multi-monitor setting in VM Console option dialog for 3.2 compatible cluster
Change multi-monitor setting in VM Console option dialog for 3.2 compatible c...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Shahar Havivi
Ilanit Stein
virt
:
: 1009057 1011924 (view as bug list)
Depends On:
Blocks: 1000039 3.3snap1
  Show dependency treegraph
 
Reported: 2013-09-18 06:44 EDT by Dušan Kajan
Modified: 2014-06-16 07:07 EDT (History)
13 users (show)

See Also:
Fixed In Version: is20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:17:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
shavivi: needinfo-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19468 None None None Never
oVirt gerrit 20340 None None None Never

  None (edit)
Description Dušan Kajan 2013-09-18 06:44:20 EDT
Description of problem:
It is impossible to create Linux VM in 3.2 compatible cluster, with default options

Version-Release number of selected component (if applicable):
3.3 is15

How reproducible:
100%

Steps to Reproduce:
1. Click Create New VM
2. Fill in name and choose operating system Linux
3. Click OK

Actual results:
The VM is not created, getting error: Cannot add VM. Cluster does not support Single Qxl Pci devices.

Expected results:
The VM should be created -> the Single PCI option in Console subtab should not be checked for 3.2 compatible cluster

Additional info:
It is possible to create VM after unchecking the Single PCI option in Console subtab. 
Regression from this BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1000039
Comment 1 Shahar Havivi 2013-09-23 09:41:16 EDT
posted at:
http://gerrit.ovirt.org/#/c/19468/
Comment 2 Michal Skrivanek 2013-09-26 09:09:11 EDT
please make sure it works correctly when you check single PCI and then change to VNC. Currently it disappears (correct) in GUI but it is sent to backend and also brings up a failure dialog. This should be handled in frontend
Comment 3 Michal Skrivanek 2013-10-02 09:35:37 EDT
*** Bug 1009057 has been marked as a duplicate of this bug. ***
Comment 4 Shahar Havivi 2013-10-07 07:08:47 EDT
(In reply to Michal Skrivanek from comment #2)
sent a new patch
Comment 5 Shahar Havivi 2013-10-08 09:41:49 EDT
*** Bug 1011924 has been marked as a duplicate of this bug. ***
Comment 9 Ilanit Stein 2013-10-27 11:01:38 EDT
Checked on is20, but got same error as in description.
Maybe fix is not included in is20?
Comment 11 Shahar Havivi 2013-10-30 07:29:47 EDT
Eyal,
After checking with Ilanit is20 don't have the fix,
The latest upstream does have the fix (the fix check for cluster version and enable qxl for 3.3 and up)
are we sure that it made it to 3.3?
Comment 12 Shai Revivo 2013-11-03 04:10:16 EST
in build 21
Comment 13 Ilanit Stein 2013-11-03 07:51:42 EST
Verified on is21.
Comment 14 Itamar Heim 2014-01-21 17:17:33 EST
Closing - RHEV 3.3 Released
Comment 15 Itamar Heim 2014-01-21 17:24:06 EST
Closing - RHEV 3.3 Released
Comment 16 Eyal Edri 2014-06-16 07:07:45 EDT
removing need info, bug was fixed.

Note You need to log in before you can comment on or make changes to this bug.