Bug 1009065 - Nova Compute requires brctl, package should have Requires: bridge-utils
Nova Compute requires brctl, package should have Requires: bridge-utils
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-nova (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Havana
Assigned To: Xavier Queralt
Gabriel Szasz
:
: 1031774 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 11:07 EDT by Sandro Mathys
Modified: 2014-06-18 03:00 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-24 03:45:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mathys 2013-09-17 11:07:58 EDT
Description of problem:
Nova Compute is trying to call brctl through nova-rootwrap but the command can not be found.

Version-Release number of selected component (if applicable):
openstack-nova-compute-2013.2-0.19.b3.el6.noarch

How reproducible:
Probably always, but haven't tested

Steps to Reproduce:
1. Install EL6.4
2. Make sure bridge-utils have not been installed already (e.g. minimal install)
3. Install OpenStack (FWIW: Havana-3, with Neutron, without Packstack)

Actual results:
[...]
2013-09-17 16:46:01.748 4457 TRACE nova.compute.manager [instance: a37b711f-e74e-4dfc-afb4-04d207f67074] ProcessExecutionError: Unexpected error while running command.
2013-09-17 16:46:01.748 4457 TRACE nova.compute.manager [instance: a37b711f-e74e-4dfc-afb4-04d207f67074] Command: sudo nova-rootwrap /etc/nova/rootwrap.conf brctl addbr qbr52facc6a-bb
2013-09-17 16:46:01.748 4457 TRACE nova.compute.manager [instance: a37b711f-e74e-4dfc-afb4-04d207f67074] Exit code: 96
2013-09-17 16:46:01.748 4457 TRACE nova.compute.manager [instance: a37b711f-e74e-4dfc-afb4-04d207f67074] Stdout: '/usr/bin/nova-rootwrap: Executable not found: brctl (filter match = brctl)\n'
2013-09-17 16:46:01.748 4457 TRACE nova.compute.manager [instance: a37b711f-e74e-4dfc-afb4-04d207f67074] Stderr: ''
[...]
2013-09-17 16:46:03.100 4457 TRACE nova.virt.libvirt.vif [instance: a37b711f-e74e-4dfc-afb4-04d207f67074] ProcessExecutionError: Unexpected error while running command.
2013-09-17 16:46:03.100 4457 TRACE nova.virt.libvirt.vif [instance: a37b711f-e74e-4dfc-afb4-04d207f67074] Command: sudo nova-rootwrap /etc/nova/rootwrap.conf brctl delif qbr52facc6a-bb qvb52facc6a-bb
2013-09-17 16:46:03.100 4457 TRACE nova.virt.libvirt.vif [instance: a37b711f-e74e-4dfc-afb4-04d207f67074] Exit code: 96
2013-09-17 16:46:03.100 4457 TRACE nova.virt.libvirt.vif [instance: a37b711f-e74e-4dfc-afb4-04d207f67074] Stdout: '/usr/bin/nova-rootwrap: Executable not found: brctl (filter match = brctl)\n'
2013-09-17 16:46:03.100 4457 TRACE nova.virt.libvirt.vif [instance: a37b711f-e74e-4dfc-afb4-04d207f67074] Stderr: ''
[...]

Expected results:
No errors :)

Additional info:
Manually installing bridge-utils on the compute nodes resolved the issue (as expected).
Comment 1 Xavier Queralt 2013-10-23 06:39:27 EDT
I'll fix this in the next build.
Comment 2 Lars Kellogg-Stedman 2013-11-18 13:01:35 EST
*** Bug 1031774 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.