Bug 1031774 - openstack-nova-compute requires bridge-utils
openstack-nova-compute requires bridge-utils
Status: CLOSED DUPLICATE of bug 1009065
Product: RDO
Classification: Community
Component: openstack-nova (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHOS Maint
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 13:00 EST by Lars Kellogg-Stedman
Modified: 2013-11-18 13:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 13:01:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2013-11-18 13:00:55 EST
Description of problem:

The openstack-nova-compute package should require: bridge-utils.  Without this package, the compute service will start correctly but new instances will fail to boot with the following error in the compute.log:

.
.
.
2013-11-18 10:56:39.693 12912 TRACE nova.compute.manager [instance: bd1ff58e-53df-4c1f-9781-3a98ee62adaa]   File "/usr/lib/python2.6/site-packages/nova/openstack/common/processutils.py", line 178, in execute
2013-11-18 10:56:39.693 12912 TRACE nova.compute.manager [instance: bd1ff58e-53df-4c1f-9781-3a98ee62adaa]     cmd=' '.join(cmd))
2013-11-18 10:56:39.693 12912 TRACE nova.compute.manager [instance: bd1ff58e-53df-4c1f-9781-3a98ee62adaa] ProcessExecutionError: Unexpected error while running command.
2013-11-18 10:56:39.693 12912 TRACE nova.compute.manager [instance: bd1ff58e-53df-4c1f-9781-3a98ee62adaa] Command: sudo nova-rootwrap /etc/nova/rootwrap.conf brctl addbr qbre0460db5-bc
2013-11-18 10:56:39.693 12912 TRACE nova.compute.manager [instance: bd1ff58e-53df-4c1f-9781-3a98ee62adaa] Exit code: 96
2013-11-18 10:56:39.693 12912 TRACE nova.compute.manager [instance: bd1ff58e-53df-4c1f-9781-3a98ee62adaa] Stdout: ''
2013-11-18 10:56:39.693 12912 TRACE nova.compute.manager [instance: bd1ff58e-53df-4c1f-9781-3a98ee62adaa] Stderr: '/usr/bin/nova-rootwrap: Executable not found: brctl (filter match = brctl)\n'
Comment 1 Lars Kellogg-Stedman 2013-11-18 13:01:35 EST

*** This bug has been marked as a duplicate of bug 1009065 ***

Note You need to log in before you can comment on or make changes to this bug.