Bug 1009094 - RFE: Upgrade F18's perl-Try-Tiny to >= 0.12
RFE: Upgrade F18's perl-Try-Tiny to >= 0.12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Try-Tiny (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1008300
  Show dependency treegraph
 
Reported: 2013-09-17 12:35 EDT by Ralf Corsepius
Modified: 2013-09-26 20:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: perl-Try-Tiny-0.12-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 20:52:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2013-09-17 12:35:28 EDT
Description of problem:

perl-Apache-LogFormat-Compiler-0.13 requires Try::Tiny >= 0.12

F18 currently ships perl-Try-Tiny-0.11, F19 currently ships perl-Try-Tiny-0.12.

I'd therefore suggest to upgrade F18's perl-Try-Tiny to the status of F19.


Additional info:
perl-Apache-LogFormat-Compiler is a new dependency of perl-Plack, which can not be bug-fixed rsp. upgraded without perl-Try-Tiny >= 0.12.

Shouldn't you have sufficient time, I'd simply git merge origin/f19 into f18 and rebuild.
Comment 1 Paul Howarth 2013-09-17 12:53:12 EDT
I wonder why they've specified version 0.12, since the changes in that release were documentation fixes...

Still, at least that means an update isn't going to break anything :-)
Comment 2 Fedora Update System 2013-09-17 12:56:47 EDT
perl-Try-Tiny-0.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-Try-Tiny-0.12-1.fc18
Comment 3 Paul Howarth 2013-09-17 13:04:06 EDT
There's a buildroot override in place for this too.

koji wait-repo f18-build --build=perl-Try-Tiny-0.12-1.fc18
Comment 4 Ralf Corsepius 2013-09-17 13:40:06 EDT
(In reply to Paul Howarth from comment #1)
> I wonder why they've specified version 0.12, since the changes in that
> release were documentation fixes...
Interesting, but dunno ... probably the version the implementor of Apache-LogFormat-Compiler has installed ;)

All I can say, ... Plack's deps are gradually becoming a maintainance nightmare. Its upstream is taking a fairly bizarre route ;)

(In reply to Fedora Update System from comment #2)
> perl-Try-Tiny-0.12-1.fc18 has been submitted as an update for Fedora 18.

Thanks.
Comment 5 Fedora Update System 2013-09-18 08:58:04 EDT
Package perl-Try-Tiny-0.12-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Try-Tiny-0.12-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16986/perl-Try-Tiny-0.12-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-09-26 20:52:22 EDT
perl-Try-Tiny-0.12-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.