Bug 1009115 - rhevm-iso-uploader - log file overwritten at each execution
rhevm-iso-uploader - log file overwritten at each execution
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-iso-uploader (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.2.4
Assigned To: Sandro Bonazzola
Jiri Belka
integration
: ZStream
Depends On: 998592
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 13:47 EDT by rhev-integ
Modified: 2013-10-25 14:12 EDT (History)
8 users (show)

See Also:
Fixed In Version: rhevm-iso-uploader-3.2.2-4.el6ev
Doc Type: Bug Fix
Doc Text:
Each ISO image upload overwrote the existing iso-uploader log file. This made debugging issues difficult, especially when multiple uploads were executed. Now, log messages are written into timestamped files by default, preventing the overwrite of existing files. The default location of the logs has been changed from /var/log/ovirt-engine to /var/log/ovirt-engine/ovirt-iso-uploader In addition, a log rotation was introduced to compress old logs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 14:12:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18301 None None None Never
oVirt gerrit 18315 None None None Never
oVirt gerrit 19392 None None None Never

  None (edit)
Description rhev-integ 2013-09-17 13:47:38 EDT
+++ This bug is a RHEV-M zstream clone. The original bug is: +++
+++   https://bugzilla.redhat.com/show_bug.cgi?id=998592. +++

======================================================================



----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on August 19 at 14:43:00, 2013

Description of problem:
Each time you attempt to upload iso, the existing iso-uploader log file gets overwritten which makes debugging issues harder when you execute multiple attempts.


How reproducible:
100%

Steps to Reproduce:
1. execute several times iso uploader

Actual results:
default log file is overwritten

Expected results:
default log file should have timestamp avoiding to be overwritten

Additional info:
Affects all versions.

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on August 20 at 07:58:56, 2013

patch pushed upstream master

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on August 20 at 08:08:38, 2013

Log messages to timestamped files as default, avoiding to overwrite existing ones.

The default location of the logs was changed, to improve /var/log/ovirt-engine sanity:

/var/log/ovirt-engine -> /var/log/ovirt-engine/ovirt-iso-uploader

A log rotation was introduced in order to compress old logs.

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on August 20 at 11:10:14, 2013

merged upstream master, pushed to 3.3 branch.

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on August 20 at 13:37:46, 2013

merged upstream 3.3 branch.

----------------------------------------------------------------------
Following comment by errata-xmlrpc@redhat.com on August 21 at 08:50:53, 2013

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2013:15254-01
http://errata.devel.redhat.com/errata/show/15254

----------------------------------------------------------------------
Following comment by istein@redhat.com on August 25 at 13:21:01, 2013

Reassign. IS11 contain: rhevm-iso-uploader-3.3.0-0.1.master.el6ev.noarch

----------------------------------------------------------------------
Following comment by knesenko@redhat.com on August 25 at 13:34:33, 2013

(In reply to Ilanit Stein from comment #6)
> Reassign. IS11 contain: rhevm-iso-uploader-3.3.0-0.1.master.el6ev.noarch

IS11 includes the correct version. Please recheck your repos

----------------------------------------------------------------------
Following comment by istein@redhat.com on August 25 at 14:08:57, 2013

Verified on is11.

Existing older tools installed prevented the new tools installation.
Comment 1 Sandro Bonazzola 2013-09-19 11:07:11 EDT
patch pushed upstream 3.2 branch.
Comment 2 Sandro Bonazzola 2013-09-24 09:41:33 EDT
patch 19392 merged upstream 3.2 branch
Comment 4 Jiri Belka 2013-10-09 11:24:24 EDT
ok, sf21.

# ls -ltr /var/log/ovirt-engine/ovirt-iso-uploader/
total 8
-rw-r--r--. 1 root root 2704 Oct  9 17:22 ovirt-iso-uploader-20131009172156.log
-rw-r--r--. 1 root root 2698 Oct  9 17:22 ovirt-iso-uploader-20131009172223.log
Comment 6 errata-xmlrpc 2013-10-25 14:12:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1466.html

Note You need to log in before you can comment on or make changes to this bug.