Bug 998592 - rhevm-iso-uploader - log file overwritten at each execution
rhevm-iso-uploader - log file overwritten at each execution
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-iso-uploader (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Ilanit Stein
integration
: ZStream
Depends On:
Blocks: 1009115
  Show dependency treegraph
 
Reported: 2013-08-19 10:43 EDT by Sandro Bonazzola
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version: rhevm-iso-uploader-3.3.0-0.3.rc.el6ev
Doc Type: Bug Fix
Doc Text:
Every time an image was uploaded, the existing log file was overwritten, making it difficult to debug issues. Now, messages are logged to timestamped files, to avoid overwriting existing ones. A log rotation was also introduced to compress old logs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:31:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18301 None None None Never
oVirt gerrit 18315 None None None Never

  None (edit)
Description Sandro Bonazzola 2013-08-19 10:43:00 EDT
Description of problem:
Each time you attempt to upload iso, the existing iso-uploader log file gets overwritten which makes debugging issues harder when you execute multiple attempts.


How reproducible:
100%

Steps to Reproduce:
1. execute several times iso uploader

Actual results:
default log file is overwritten

Expected results:
default log file should have timestamp avoiding to be overwritten

Additional info:
Affects all versions.
Comment 1 Sandro Bonazzola 2013-08-20 03:58:56 EDT
patch pushed upstream master
Comment 2 Sandro Bonazzola 2013-08-20 04:08:38 EDT
Log messages to timestamped files as default, avoiding to overwrite existing ones.

The default location of the logs was changed, to improve /var/log/ovirt-engine sanity:

/var/log/ovirt-engine -> /var/log/ovirt-engine/ovirt-iso-uploader

A log rotation was introduced in order to compress old logs.
Comment 3 Sandro Bonazzola 2013-08-20 07:10:14 EDT
merged upstream master, pushed to 3.3 branch.
Comment 4 Sandro Bonazzola 2013-08-20 09:37:46 EDT
merged upstream 3.3 branch.
Comment 6 Ilanit Stein 2013-08-25 09:21:01 EDT
Reassign. IS11 contain: rhevm-iso-uploader-3.3.0-0.1.master.el6ev.noarch
Comment 7 Kiril Nesenko 2013-08-25 09:34:33 EDT
(In reply to Ilanit Stein from comment #6)
> Reassign. IS11 contain: rhevm-iso-uploader-3.3.0-0.1.master.el6ev.noarch

IS11 includes the correct version. Please recheck your repos
Comment 8 Ilanit Stein 2013-08-25 10:08:57 EDT
Verified on is11.

Existing older tools installed prevented the new tools installation.
Comment 10 errata-xmlrpc 2014-01-21 11:31:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0077.html

Note You need to log in before you can comment on or make changes to this bug.