This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1009116 - rhevm-log-collector - log file overwritten at each execution
rhevm-log-collector - log file overwritten at each execution
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.2.4
Assigned To: Sandro Bonazzola
sefi litmanovich
integration
: ZStream
Depends On: 998576
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 13:49 EDT by rhev-integ
Modified: 2013-10-25 14:12 EDT (History)
7 users (show)

See Also:
Fixed In Version: rhevm-log-collector-3.2.2-5.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 14:12:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18299 None None None Never
oVirt gerrit 18312 None None None Never
oVirt gerrit 19405 None None None Never

  None (edit)
Description rhev-integ 2013-09-17 13:49:53 EDT
+++ This bug is a RHEV-M zstream clone. The original bug is: +++
+++   https://bugzilla.redhat.com/show_bug.cgi?id=998576. +++

======================================================================



----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on August 19 at 14:25:27, 2013

Description of problem:
Each time you attempt to collect logs, the existing log-collector log file gets overwritten which makes debugging issues harder when you execute multiple attempts.


How reproducible:
100%

Steps to Reproduce:
1. execute several times log collector

Actual results:
default log file is overwritten

Expected results:
default log file should have timestamp avoiding to be overwritten

Additional info:
Affects all versions.

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on August 20 at 07:34:26, 2013

patch pushed upstream master

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on August 20 at 08:09:36, 2013

Log messages to timestamped files as default, avoiding to overwrite existing ones.

The default location of the logs was changed, to improve /var/log/ovirt-engine sanity.

/var/log/ovirt-engine -> /var/log/ovirt-engine/ovirt-log-collector

A log rotation was introduced in order to compress old logs.

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on August 20 at 10:57:55, 2013

merged upstream master, pushed to 3.3 branch.

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on August 21 at 05:50:58, 2013

merged upstream 3.3 branch

----------------------------------------------------------------------
Following comment by errata-xmlrpc@redhat.com on August 21 at 08:15:16, 2013

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2013:15255-01
http://errata.devel.redhat.com/errata/show/15255

----------------------------------------------------------------------
Following comment by istein@redhat.com on August 25 at 13:19:36, 2013

Reassign. IS11 contain: rhevm-log-collector-3.3.0-0.1.master.el6ev.noarch

----------------------------------------------------------------------
Following comment by knesenko@redhat.com on August 25 at 13:32:42, 2013

(In reply to Ilanit Stein from comment #6)
> Reassign. IS11 contain: rhevm-log-collector-3.3.0-0.1.master.el6ev.noarch

IS11 includes the correct version. Please recheck your repos

----------------------------------------------------------------------
Following comment by istein@redhat.com on August 25 at 14:05:50, 2013

Verified on is11.

Existing older tools installed, prevented the new tools installation.
Comment 1 Sandro Bonazzola 2013-09-20 04:54:27 EDT
patch pushed upstream 3.2 branch
Comment 2 Sandro Bonazzola 2013-09-24 09:40:22 EDT
patch 19405 merged upstream 3.2 branch
Comment 4 sefi litmanovich 2013-10-03 05:10:42 EDT
verified on RHEVM 3.3 IS17.
rhevm-log-collector-3.3.0-1.el6ev.noarch
sos-2.2-44.el6.noarch
Comment 5 Sandro Bonazzola 2013-10-03 05:25:14 EDT
(In reply to sefi litmanovich from comment #4)
> verified on RHEVM 3.3 IS17.
> rhevm-log-collector-3.3.0-1.el6ev.noarch
> sos-2.2-44.el6.noarch

should be verified with rhevm-log-collector-3.2.2-5.el6ev
moving back to ON_QA
Comment 8 errata-xmlrpc 2013-10-25 14:12:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1465.html

Note You need to log in before you can comment on or make changes to this bug.