Bug 998576 - rhevm-log-collector - log file overwritten at each execution
rhevm-log-collector - log file overwritten at each execution
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Ilanit Stein
integration
: ZStream
Depends On:
Blocks: 1009116
  Show dependency treegraph
 
Reported: 2013-08-19 10:25 EDT by Sandro Bonazzola
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version: rhevm-log-collector-3.3.0-0.2.rc.el6ev
Doc Type: Bug Fix
Doc Text:
Each log collection overwrote the existing log file. This made debugging issues difficult, especially when multiple attempts were executed. Now, log messages are written into timestamped files by default, preventing the overwrite of existing files. The default location of the logs has been changed from /var/log/ovirt-engine to /var/log/ovirt-engine/ovirt-log-collector. In addition, a log rotation was introduced to compress old logs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:59:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18299 None None None Never
oVirt gerrit 18312 None None None Never

  None (edit)
Description Sandro Bonazzola 2013-08-19 10:25:27 EDT
Description of problem:
Each time you attempt to collect logs, the existing log-collector log file gets overwritten which makes debugging issues harder when you execute multiple attempts.


How reproducible:
100%

Steps to Reproduce:
1. execute several times log collector

Actual results:
default log file is overwritten

Expected results:
default log file should have timestamp avoiding to be overwritten

Additional info:
Affects all versions.
Comment 1 Sandro Bonazzola 2013-08-20 03:34:26 EDT
patch pushed upstream master
Comment 2 Sandro Bonazzola 2013-08-20 04:09:36 EDT
Log messages to timestamped files as default, avoiding to overwrite existing ones.

The default location of the logs was changed, to improve /var/log/ovirt-engine sanity.

/var/log/ovirt-engine -> /var/log/ovirt-engine/ovirt-log-collector

A log rotation was introduced in order to compress old logs.
Comment 3 Sandro Bonazzola 2013-08-20 06:57:55 EDT
merged upstream master, pushed to 3.3 branch.
Comment 4 Sandro Bonazzola 2013-08-21 01:50:58 EDT
merged upstream 3.3 branch
Comment 6 Ilanit Stein 2013-08-25 09:19:36 EDT
Reassign. IS11 contain: rhevm-log-collector-3.3.0-0.1.master.el6ev.noarch
Comment 7 Kiril Nesenko 2013-08-25 09:32:42 EDT
(In reply to Ilanit Stein from comment #6)
> Reassign. IS11 contain: rhevm-log-collector-3.3.0-0.1.master.el6ev.noarch

IS11 includes the correct version. Please recheck your repos
Comment 8 Ilanit Stein 2013-08-25 10:05:50 EDT
Verified on is11.

Existing older tools installed, prevented the new tools installation.
Comment 10 Charlie 2013-11-27 20:16:47 EST
This bug is currently attached to errata RHBA-2013:15255. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 11 errata-xmlrpc 2014-01-21 11:59:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0039.html

Note You need to log in before you can comment on or make changes to this bug.