Bug 100915 - package is not Gnome HIG compliant in field
Summary: package is not Gnome HIG compliant in field
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: beta1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-07-27 01:15 UTC by Pedro Miguel Marques Morais
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 12:49:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HIGify labels (56.47 KB, patch)
2003-07-27 01:16 UTC, Pedro Miguel Marques Morais
no flags Details | Diff

Description Pedro Miguel Marques Morais 2003-07-27 01:15:30 UTC
This package is not Gnome HIG compliant in field labels. 
Field labels should be in sentence capitalization, not title capitalization. 
http://developer.gnome.org/projects/gup/hig/1.0/controls.html#controls-entry 
"Label the entry field with a text label above it or to its left, using sentence capitalization. " 
The KDE HIG also agrees with Gnome in this matter. 
Patch attached (against HEAD). 
Will generate 79 fuzzy messages, please apply as soon as possible.

Comment 1 Pedro Miguel Marques Morais 2003-07-27 01:16:26 UTC
Created attachment 93169 [details]
HIGify labels

Comment 2 Pedro Miguel Marques Morais 2003-07-28 22:23:56 UTC
Since I'm a kind of i18n guy, I've developed a script (still in tests!) that I used to this violations; 
the theory is that the original text as to be good so that it have a good translation. 
I would like to do the same for the rest of the redhat-config-* packages, but I filled this bug first 
just to see how you would react; should I continue this work? 

Comment 3 Harald Hoyer 2003-07-29 08:27:38 UTC
well, ok... if it's the guideline, why not..

Comment 4 Harald Hoyer 2003-07-30 12:49:53 UTC
applied in CVS


Note You need to log in before you can comment on or make changes to this bug.