Bug 1009168 - dhclient-4.2.5-21.fc21.x86_64 segfaults on boot
dhclient-4.2.5-21.fc21.x86_64 segfaults on boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
: 1009259 1009814 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 17:20 EDT by Nicolas Mailhot
Modified: 2013-09-19 04:36 EDT (History)
6 users (show)

See Also:
Fixed In Version: dhcp-4.2.5-22.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 03:09:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-09-17 17:20:35 EDT
dhclient-4.2.5-21.fc21.x86_64 segfaults on boot
Comment 1 Joachim Backes 2013-09-18 00:13:01 EDT
Same problem with dhclient-4.2.5-21.fc20.x86_64 in F20 (NetworkManager complaints about dhclient problems during boot)
Comment 2 Ankur Sinha (FranciscoD) 2013-09-18 00:59:24 EDT
I'm seeing this too. It doesn't only happen at boot. It happens all the time.

Everytime I restart NetworkManager.service, dhclient segfaults. This is what journalctl -xb says:

Sep 18 14:47:25 ankur.pc dhclient[10363]: Internet Systems Consortium DHCP Client 4.2.5
Sep 18 14:47:25 ankur.pc dhclient[10363]: Copyright 2004-2013 Internet Systems Consortium.
Sep 18 14:47:25 ankur.pc dhclient[10363]: All rights reserved.
Sep 18 14:47:25 ankur.pc dhclient[10363]: For info, please visit https://www.isc.org/software/dhcp/
Sep 18 14:47:25 ankur.pc dhclient[10363]: Sep 18 14:47:25 ankur.pc NetworkManager[10264]: Internet Systems Consortium DHCP Client 4.2.5
Sep 18 14:47:25 ankur.pc NetworkManager[10264]: Copyright 2004-2013 Internet Systems Consortium.
Sep 18 14:47:25 ankur.pc NetworkManager[10264]: All rights reserved.
Sep 18 14:47:25 ankur.pc NetworkManager[10264]: For info, please visit https://www.isc.org/software/dhcp/
Sep 18 14:47:25 ankur.pc NetworkManager[10264]: <info> (p1p1): DHCPv4 state changed nbi -> preinit
Sep 18 14:47:25 ankur.pc dhclient[10363]: Listening on LPF/p1p1/f0:4d:a2:aa:22:b0
Sep 18 14:47:25 ankur.pc dhclient[10363]: Sending on   LPF/p1p1/f0:4d:a2:aa:22:b0
Sep 18 14:47:25 ankur.pc NetworkManager[10264]: Listening on LPF/p1p1/f0:4d:a2:aa:22:b0
Sep 18 14:47:25 ankur.pc NetworkManager[10264]: Sending on   LPF/p1p1/f0:4d:a2:aa:22:b0
Sep 18 14:47:25 ankur.pc kernel: dhclient[10363]: segfault at 0 ip 00007f2c654f42f1 sp 00007fff837ec270 error 4 in dhclient[7f2c654ae000+64000]
Sep 18 14:47:25 ankur.pc abrt[10365]: Saved core dump of pid 10363 (/usr/sbin/dhclient) to /var/tmp/abrt/ccpp-2013-09-18-14:47:25-10363 (13193216 bytes)
Sep 18 14:47:25 ankur.pc abrtd[478]: New client connected
Sep 18 14:47:25 ankur.pc NetworkManager[10264]: <info> (p1p1): DHCPv4 client pid 10363 exited with status -1
Sep 18 14:47:25 ankur.pc NetworkManager[10264]: <warn> DHCP client died abnormally

I'm trying to get abrt to generate a proper backtrace. Will provide a bug link as soon as it's ready. 


***
Currently, it is impossible to connect to *any* network with this version of dhclient.

I tried: ethernet, wireless and usb tethering.


***

Downgrading to 4.2.5-20 fixes it.

Thanks,
Warm regards,
Ankur
Comment 3 Ankur Sinha (FranciscoD) 2013-09-18 01:12:54 EDT
Abrt is unable to generate a backtrace here. Sorry :/
Comment 4 Ankur Sinha (FranciscoD) 2013-09-18 01:30:37 EDT
Abrt bug added with backtrace etc information.
Comment 5 Jiri Popelka 2013-09-18 03:04:18 EDT
*** Bug 1009259 has been marked as a duplicate of this bug. ***
Comment 6 Jiri Popelka 2013-09-18 03:09:04 EDT
I'm sorry for the inconvenience caused by lack of testing on my side.
Should be fixed with:
dhcp-4.2.5-22.fc21
dhcp-4.2.5-22.fc20
dhcp-4.2.5-22.fc19
Comment 7 Rolf Fokkens 2013-09-18 10:10:12 EDT
I tested the proposed RPMS (from koji), works OK here.
Comment 8 Ankur Sinha (FranciscoD) 2013-09-18 21:37:33 EDT
-22 fixes it. Karma given to update. Thanks for the quick fix Jiri. 

Warm regards,
Ankur
Comment 9 Jiri Popelka 2013-09-19 04:36:18 EDT
*** Bug 1009814 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.