Bug 1009814 - dhclient segfault
dhclient segfault
Status: CLOSED DUPLICATE of bug 1009168
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 04:17 EDT by Michele Baldessari
Modified: 2013-09-19 04:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 04:36:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michele Baldessari 2013-09-19 04:17:57 EDT
Description of problem:
After last night's F20 upgrade dhclient segfaults here with 'dhclient <interface>':

(gdb) bt
#0  if_register_socket (info=info@entry=0x7f0ad2e73840, family=family@entry=2, 
    do_multicast=do_multicast@entry=0x0) at socket.c:248
#1  0x00007f0ad1aba52c in if_register_fallback (info=0x7f0ad2e73840) at socket.c:325
#2  0x00007f0ad1aa4479 in maybe_setup_fallback () at lpf.c:584
#3  0x00007f0ad1a9e10e in discover_interfaces (state=4) at discover.c:954
#4  0x00007f0ad1a8018a in main (argc=<optimized out>, argv=<optimized out>) at dhclient.c:922
(gdb) 
#0  if_register_socket (info=info@entry=0x7f0ad2e73840, family=family@entry=2, 
    do_multicast=do_multicast@entry=0x0) at socket.c:248
#1  0x00007f0ad1aba52c in if_register_fallback (info=0x7f0ad2e73840) at socket.c:325
#2  0x00007f0ad1aa4479 in maybe_setup_fallback () at lpf.c:584
#3  0x00007f0ad1a9e10e in discover_interfaces (state=4) at discover.c:954
#4  0x00007f0ad1a8018a in main (argc=<optimized out>, argv=<optimized out>) at dhclient.c:922


Version-Release number of selected component (if applicable):
dhclient-4.2.5-21.fc20.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jiri Popelka 2013-09-19 04:36:18 EDT
I'm sorry.

*** This bug has been marked as a duplicate of bug 1009168 ***

Note You need to log in before you can comment on or make changes to this bug.