Bug 100918 - redhat-credits causes audio distortion, but the ogg file by itself doesn't
redhat-credits causes audio distortion, but the ogg file by itself doesn't
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-artwork (Show other bugs)
beta1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Alexander Larsson
:
: 81209 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-26 23:03 EDT by George Karabin
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-08 10:22:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fixes the audio stuttering (837 bytes, patch)
2003-07-26 23:09 EDT, George Karabin
no flags Details | Diff

  None (edit)
Description George Karabin 2003-07-26 23:03:46 EDT
If I play /usr/share/redhat-credits.ogg with ogg123, it sounds nice a nice
guitar solo. If I run /usr/libexec/redhat-credits instead, I immediately hear a
low frequency ticking, at a couple of Hz. Then within a few seconds the guitar
begins to play, with the ticking accompanying it. It almost sounds like a drum
machine in the background - because the ticking isn't quite periodic it has some
rhythm to it.

P.S. Nice tune. Sounds like something that Margo of the Cowboy Junkies ought to
be singing to.
Comment 1 George Karabin 2003-07-26 23:09:08 EDT
Created attachment 93172 [details]
fixes the audio stuttering

All of the console output that ogg123 is generating is returnin a ton of error
messages, given the high rate at which it writes to the console. Using dup2 and
/dev/null is much more smooth - apparently it's a lot more expensive to write
to a nonexisting file handle than an existing one.

On my 1GHz Athlon, this is definitely noticeable. Maybe different grades of
hardware don't see the problem, maybe they do. In any case, a patch that makes
the program much more smooth is attached. :)
Comment 2 Miloslav Trmac 2003-07-27 17:20:22 EDT
Doh! I was suspecting the kernel...
What really happens is that the ogg123 uses file descriptor 2 for /dev/dsp
(because of the close (1), close (2) that shouldn't be there), and is sending
its status information with the sound data.
Comment 3 Miloslav Trmac 2003-07-27 17:23:10 EDT
*** Bug 81209 has been marked as a duplicate of this bug. ***
Comment 4 George Karabin 2003-07-27 18:21:14 EDT
Oops - yeah, that's what's going on. The "error message" theory was obviously a
product of sleep deprivation.... :)
Comment 5 Havoc Pennington 2003-07-27 20:39:55 EDT
Indeed, this looks like the right patch.
Doh. Fortunately I don't think I wrote that part of the code ;-)
Comment 6 Alexander Larsson 2003-08-06 05:48:43 EDT
I checked in the fix. It'll be in the next redhat-artwork build.
Comment 7 Alexander Larsson 2003-08-08 10:22:29 EDT
Fixed in 0.78-1

Note You need to log in before you can comment on or make changes to this bug.