Bug 1009200 - XML debugging info is sent to the wrong div in Chrome
XML debugging info is sent to the wrong div in Chrome
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.3
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 21:00 EDT by Misty Stanley-Jones
Modified: 2014-06-18 03:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 13968, PressGang CCMS Handbook-2.0-1 Build Date: 18-09-2013 08:22:49 Topic ID: 13979-537703 [Latest]
Last Closed: 2013-12-03 17:16:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misty Stanley-Jones 2013-09-17 21:00:30 EDT
In Chrome 29.0.1547.65 on OS X, the XML debugging error message is not sent to the error message div, but is sent to the rendered output div. The error shows just under the topic title in the rendered output, and contains raw XML and HTML. For instance:

<parsererror><h3>This page contains the following errors:</h3><div>error on line 984 at column 16: Opening and ending tag mismatch: section line 0 and para </div><h3>Below is a rendering of the page up to the first error.</h3></parsererror>
Comment 1 Lee Newson 2013-09-18 03:04:13 EDT
Generally the error should display in both places so I doubt it was being sent to the wrong div. Was there a specific sequence of elements this occurred for Misty, or was it just any errors? Also it wasn't just left over from a previous error was it (the renderer only refreshes about every 2 secs, while the errors refresh a lot faster)?
Comment 2 Lee Newson 2013-09-18 03:09:21 EDT
Forgot to mention that perhaps the renderer shouldn't be attempting to display invalid content, but Matt would be able to say if it should be rendered.
Comment 3 Matthew Casperson 2013-09-23 21:12:53 EDT
Different browsers will attempted to render invalid XML is different ways. This is browser dependent and is not something we have control over.
Comment 6 Lee Newson 2013-10-12 03:26:12 EDT
Since we can't replicate this I believe it should be closed. However the part that should be decided on is if invalid XML should be sent to be rendered (mainly so the user experience is the same regardless of browser)? So I'm setting the needinfo flag for Matt, to get an answer to that question.
Comment 7 Lee Newson 2013-12-02 22:35:16 EST
The information from above is no longer needed because as part of BZ#1019050 it won't render invalid XML anymore which will remove the browser specific error messages Misty saw. We've also included some loading information in the XML Error text box so that you can see that the DTD or whatever is loading. Anyways since this couldn't be replicated and we've removed the possibility to try and render invalid XML I'm going to mark this as RELEASE_PENDING (since 1.3 isn't release yet).

Note You need to log in before you can comment on or make changes to this bug.