Bug 1019050 - RFE: Replace entities with those defined in a content spec in the live renderer
RFE: Replace entities with those defined in a content spec in the live renderer
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.3
Assigned To: Lee Newson
:
Depends On: 864616 1013882
Blocks: 965921
  Show dependency treegraph
 
Reported: 2013-10-15 01:18 EDT by Matthew Casperson
Modified: 2014-08-04 18:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 17:16:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Casperson 2013-10-15 01:18:50 EDT
Now that entities can be defined (https://bugzilla.redhat.com/show_bug.cgi?id=864616) we should allow the live renderer to make use of those entities.
Comment 1 Lee Newson 2013-10-15 19:04:00 EDT
This should probably only be implemented once full entity support is included to make sure it doesn't cause translation issues (see BZ#1013882).
Comment 2 Lee Newson 2013-11-25 20:10:37 EST
Added in 1.3-SNAPSHOT build 201311261027

The renderer will now display a list of Content Specs that have either a condition or custom entities, instead of the old list that just displayed the different conditions. To see the entities or conditions used in the content spec, there is a new info button beside the dropdown list that will open up a dialog box with the rendering information.

The validator has also been updated to pull all the custom entities from the content specs that the topic is used in and add them to the XML before it is sent for validation.

Note: This is deployed on the development/test server.
Comment 6 Lee Newson 2013-11-27 21:19:12 EST
Fixed in 1.3-SNAPSHOT build 201311281207

Previously when the XML was being rendered it would attempt to convert the XML into a DOM Document, however if that failed then it would just send the XML as is to the renderer. Now I've updated this to catch any parsing errors (so where invalid custom entities would be detected) and then process the error to display an error message in the rendering panel.

Doing this also has the added benefit of fixing BZ#1009200 since invalid XML is no longer sent to be rendered.

Note: This version is currently live on the test/development server.
Comment 7 Matthew Casperson 2013-11-27 21:28:14 EST
Tested topics with a mix of custom and standard docbook entities, and warnings for topics with missing entities were displayed as expected.

Note You need to log in before you can comment on or make changes to this bug.