Bug 1009394 - Trackpointer on ThinkPad USB keyboard stopped working with kernel-3.10.11-200.fc19.x86_64
Trackpointer on ThinkPad USB keyboard stopped working with kernel-3.10.11-200...
Status: CLOSED DUPLICATE of bug 1003998
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 1009354 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 06:52 EDT by David Sommerseth
Modified: 2016-05-22 19:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 08:48:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Sommerseth 2013-09-18 06:52:16 EDT
Description of problem:
When booting 3.10.11-200 the trackpointer mouse on the Lenovo ThinkPad USB keyboard with trackpointer [1] stopped working.

From dmesg, I see this:

----------------------------------------------
[   38.813865] input: Lite-On Technology Corp. ThinkPad USB Keyboard with TrackPoint as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-
1.5.3/1-1.5.3:1.0/input/input10
[   38.814238] lenovo_tpkbd 0003:17EF:6009.0002: input,hidraw2: USB HID v1.10 Keyboard [Lite-On Technology Corp. ThinkPad USB Keyboard wit
h TrackPoint] on usb-0000:00:1a.0-1.5.3/input0
[   38.816274] input: Lite-On Technology Corp. ThinkPad USB Keyboard with TrackPoint as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-
1.5.3/1-1.5.3:1.1/input/input11
[   38.816666] lenovo_tpkbd 0003:17EF:6009.0003: input,hiddev0,hidraw3: USB HID v1.10 Mouse [Lite-On Technology Corp. ThinkPad USB Keyboar
d with TrackPoint] on usb-0000:00:1a.0-1.5.3/input1
[   38.816670] lenovo_tpkbd 0003:17EF:6009.0003: missing HID_OUTPUT_REPORT 4
----------------------------------------------



When booting kernel-3.10.10-200.fc19.x86_64, the last line is not present:
----------------------------------------------
[   28.255535] input: Lite-On Technology Corp. ThinkPad USB Keyboard with TrackPoint as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5.3/1-1.5.3:1.0/input/input10
[   28.255748] lenovo_tpkbd 0003:17EF:6009.0002: input,hidraw2: USB HID v1.10 Keyboard [Lite-On Technology Corp. ThinkPad USB Keyboard with TrackPoint] on usb-0000:00:1a.0-1.5.3/input0
[   28.257972] input: Lite-On Technology Corp. ThinkPad USB Keyboard with TrackPoint as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5.3/1-1.5.3:1.1/input/input11
[   28.258302] lenovo_tpkbd 0003:17EF:6009.0003: input,hiddev0,hidraw3: USB HID v1.10 Mouse [Lite-On Technology Corp. ThinkPad USB Keyboard with TrackPoint] on usb-0000:00:1a.0-1.5.3/input1
----------------------------------------------

[1] http://www.amazon.com/ThinkPad-USB-Keyboard-with-TrackPoint/dp/B002ONCC6G


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Boot computer into a graphical environment
2. Try to use the trackpointer on the external Thinkpad USB keyboard

Actual results:
The mouse does not move when the trackpointer on the ThinkPad USB keyboard is used.  On the laptop itself, the trackpointer does work fine.

Expected results:
The mouse to move, regardless of which trackpointer being used.


Additional info:
# lsusb -s 1:6 -v

Bus 001 Device 006: ID 17ef:6009 Lenovo ThinkPad Keyboard with TrackPoint
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x17ef Lenovo
  idProduct          0x6009 ThinkPad Keyboard with TrackPoint
  bcdDevice            1.27
  iManufacturer           1 Lite-On Technology Corp.
  iProduct                2 ThinkPad USB Keyboard with TrackPoint
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           59
    bNumInterfaces          2
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      1 Boot Interface Subclass
      bInterfaceProtocol      1 Keyboard
      iInterface              0 
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.10
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      65
         Report Descriptors: 
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              10
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      0 No Subclass
      bInterfaceProtocol      0 None
      iInterface              0 
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.10
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength     185
         Report Descriptors: 
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              10
Device Status:     0x0000
  (Bus Powered)
Comment 1 David Sommerseth 2013-09-18 06:56:08 EDT
Just to be clear.  The trackpointer worked fine on kernel-3.10.10-200.fc19.x86_64 and earlier versions.  This issue appears only when booting the currently newest kernel, kernel-3.10.11-200.fc19.x86_64.
Comment 2 Josh Boyer 2013-09-18 08:42:46 EDT
*** Bug 1009354 has been marked as a duplicate of this bug. ***
Comment 3 Josh Boyer 2013-09-18 08:48:08 EDT
Please update to 3.10.12 in f18 updates-testing, or 3.11.1 in f19 updates-testing.  There was a CVE fix that went in and broke this setup.  It has been fixed in those kernels.

*** This bug has been marked as a duplicate of bug 1003998 ***

Note You need to log in before you can comment on or make changes to this bug.