Bug 1009398 - Empty list of available subscriptions for system
Empty list of available subscriptions for system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Walden Raines
Sachin Ghai
: Triaged
: 1015256 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 07:10 EDT by Ivan Necas
Modified: 2014-04-24 13:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
subscriptions are visible under system's subscriptions tab. (62.65 KB, image/png)
2013-10-22 09:17 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Ivan Necas 2013-09-18 07:10:09 EDT
Steps to Reproduce:
1. register a system (with actiovation key, but it's probably not relevant) into Library
2. create new custom product and repo
3. show the system details: subscriptions tab

Actual results:
 
  no available susbcriptions 

Expected results:

  the product available to subscribe

Additional info:

   subscription-manager list --available

shows the product correctly and I can susbcribe. After subscribing, I can see the system UI susbcribed to the product
Comment 1 RHEL Product and Program Management 2013-09-18 07:15:19 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Walden Raines 2013-09-27 17:21:40 EDT
PR:  https://github.com/Katello/katello/pull/3053
Comment 4 Walden Raines 2013-09-30 16:45:08 EDT
commit a287a6aabbd0194a3fba15245b40e8820979f357
Merge: 2a950d6 d9036b8
Author: Walden Raines <walden@redhat.com>
Date:   Mon Sep 30 13:44:12 2013 -0700

    Merge pull request #3053 from waldenraines/bug-1009398
    
    Bug #1009398 - allow checkboxes for subscription filters, fixes #3029.

commit d9036b8b7fc5854347159c318acc3fbe3b9508b3
Author: Walden Raines <walden@redhat.com>
Date:   Fri Sep 27 17:18:49 2013 -0400

    Bug #1009398 - allow checkboxes for subscription filters, fixes #3029.
    
    The subscriptions page was using user preferences for filtering subscriptions
    rather than user supplied values.  This allows the user to control filtering.
Comment 7 Walden Raines 2013-10-07 15:35:13 EDT
Think we may have tracked this down, doubt it will be verifiable as is.
Comment 8 Walden Raines 2013-10-07 15:40:28 EDT
Thinking the issue is an encoded '/' in the url. Note the %2F below:

katello/api/systems/cfd2094d-0483-4e02-aa58-dbd4e9c42fcc/subscriptions%2Favailable?offset=0&search=
Comment 9 Walden Raines 2013-10-07 15:52:37 EDT
PR:  https://github.com/Katello/katello/pull/3109
Comment 10 Walden Raines 2013-10-07 16:46:17 EDT
commit 15b5305eedfb85433b470597cefbbb9765c58e8a
Merge: b2bfe85 1c2c5aa
Author: Walden Raines <walden@redhat.com>
Date:   Mon Oct 7 13:44:48 2013 -0700

    Merge pull request #3109 from waldenraines/bug-3029
    
    Bug #1009398 - fix %2f (/) in available subscriptions url, fixes #3029.

commit 1c2c5aae2c8c657d8f885c10391c907475d80ddf
Author: Walden Raines <walden@redhat.com>
Date:   Mon Oct 7 15:49:42 2013 -0400

    Bug #1009398 - fix %2f (/) in available subscriptions url, fixes #3029.
Comment 13 Tom McKay 2013-10-15 13:41:20 EDT
*** Bug 1015256 has been marked as a duplicate of this bug. ***
Comment 14 Sachin Ghai 2013-10-18 04:49:02 EDT
Verified with snap6 compose2 (MDP2)

katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.7-6.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
katello-cli-1.4.3-24.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch


I registered a system via rhsm and command I used is:

subscription-manager register --username admin --password admin --org org-name --env env-name/cv-pub-name --force 

System was registered successfully, but I can't see any subscription under the system-> subscription tab.


"subscription-manager list --available" command  shows the product correctly and I can susbcribe. After subscribing, I can see the system UI subscribed to the product.
Comment 18 Sachin Ghai 2013-10-22 09:14:00 EDT
Verified with MDP2 Snap6 Compose3.

[root@HOST201-143 ~]# rpm -qa | grep katello
katello-1.4.6-44.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-configure-1.4.7-7.el6sat.noarch
katello-glue-elasticsearch-1.4.6-44.el6sat.noarch
katello-foreman-all-1.4.6-44.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-44.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
katello-cli-1.4.3-26.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-glue-pulp-1.4.6-44.el6sat.noarch
katello-glue-candlepin-1.4.6-44.el6sat.noarch
katello-cli-common-1.4.3-26.el6sat.noarch
katello-all-1.4.6-44.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch

I can see the subscription under registered systems's subscriptions tab.
Comment 19 Sachin Ghai 2013-10-22 09:17:03 EDT
Created attachment 814999 [details]
subscriptions are visible under system's subscriptions tab.
Comment 20 Bryan Kearney 2014-04-24 13:09:51 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 21 Bryan Kearney 2014-04-24 13:11:14 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.