Bug 1015256 - Unable to subscribe custom repos from system's --> subscriptions tab
Unable to subscribe custom repos from system's --> subscriptions tab
Status: CLOSED DUPLICATE of bug 1009398
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
high Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 14:14 EDT by Sachin Ghai
Modified: 2013-10-15 13:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 13:41:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Ghai 2013-10-03 14:14:08 EDT
Description of problem:
Custom repos are not available  under system --> All --> select registered system --> subscription tab

I created a custom product via content--> Product and later promote it to next env(test). Then registered a system with env test.

Version-Release number of selected component (if applicable):
katello-1.4.8-1.git.37.b37a904.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. Created custom product/repo
2. Publish it and promote it to next env 'test'
3. register a system vai rhsm against env 'test'
4. Go to system-. All --> select registered system --> susbscriptions tab

Actual results:
custom repos are not available to subscribe

Expected results:
user should be able to subscribe a system to custom repos from system's subscription tab

Additional info:
Comment 2 Justin Sherrill 2013-10-07 08:49:15 EDT
In this case did the system get registered to 'test' or to 'test/VIEW_NAME', 

The statement:  register a system vai rhsm against env 'test'  indicates it was against just the environment, which really shouldn't have been possible.
Comment 3 Sachin Ghai 2013-10-08 07:11:32 EDT
I registered the system against just the env 'test'.
Comment 4 Tom McKay 2013-10-15 13:41:20 EDT

*** This bug has been marked as a duplicate of bug 1009398 ***

Note You need to log in before you can comment on or make changes to this bug.