Bug 1009408 - updating to ejabberd-0:2.1.13-4.fc19.x86_64 causes software update and poweroff menu entry issues
updating to ejabberd-0:2.1.13-4.fc19.x86_64 causes software update and powero...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ejabberd (Show other bugs)
19
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
: 1023664 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 07:31 EDT by collura
Modified: 2013-11-10 01:54 EST (History)
5 users (show)

See Also:
Fixed In Version: couchdb-1.3.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 02:30:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xsession errors file (8.39 KB, text/plain)
2013-09-18 07:33 EDT, collura
no flags Details
Xorg-0-log while new ejabberd installed but dont think rebooted after install... (41.28 KB, text/plain)
2013-09-18 07:34 EDT, collura
no flags Details
dmesg with ejabberd installed but dont think rebooted after install.... (123.90 KB, text/plain)
2013-09-18 07:36 EDT, collura
no flags Details
var log messages of updating of ejabberd (154.02 KB, text/plain)
2013-09-18 07:37 EDT, collura
no flags Details

  None (edit)
Description collura 2013-09-18 07:31:55 EDT
Description of problem:

for now reporting against ejabberd but expect that will change.

something messess up the software-repo-update-source-modification-gui and the poweroff/suspend toolbar menu entry:

with a currently update system (updates, updates-testing repos)
if all updated and only ejabberd-* is downgraded to 2.1.13-1 then all is well:

  software-update-source-gui (can add remove software and repos from list) 
  and 
  gnome-shell toolbarmenu has the poweroff/suspend entry visible.

but if update ejabberd to 2.1.13-4 then

  cant add/remove software or repo from software-update-source gui
  and
  gnome-shell toolbarmenu only has 
    the notifications, settings, logout and lock menu entries
    but is missing the poweroff/suspend menu entry

expect that is not not ejabberd but possibly how ejabberd interacts with something?

ejabberd depends on several packages including systemd and polkit
the ejabberd update 2.1.13-4.fc19 added systemd and polkit changes
https://admin.fedoraproject.org/updates/FEDORA-2013-16906/ejabberd-2.1.13-4.fc19
   "Use polkit instead of usermode on modern systems
    Restore user/group provides
    Fix FTBFS in F-20/Rawhide
   "

tried uninstall all the gnome-shell-extensions and gnome-tweak-tool various times but didnt seem to have an effect on problem.

(possibly the some of the gnome-shell-extensions and gnome-tweak-tool uninstall tests didnt execute because used the impaired software-gui for part of the test instead of yum commandline but would need to check.)  

at somepoint reinstalled gnome-tweak-tool and various gnome-shell-extensions to make gnome-shell useable while running tests and still the only thing that made a difference was the version of ejabberd so dont expect that it was an extension problem even though seems most logical and was first thought?  

tried downgrade systemd, polkit, and various others but the only thing that had an effect was ejabberd version.

Version-Release number of selected component (if applicable):

  gnome-shell-3.8.4-2.fc19.x86_64

  ejabberd-0:2.1.13-1.fc19.x86_64 lets things work
  ejabberd-0:2.1.13-4.fc19.x86_64 seems to trigger the brokenness

How reproducible:

 always

Steps to Reproduce:
1. fully update system and find that no poweroff or suspend option in menu
2. 'yum --disablerepo=updates-testing distro-sync' to fix lost functionality
3. reinstall all the updates and find system broken again
4. 'yum downgrade ejabberd-*' to downgrade to ejabberd-0:2.1.13-1.fc19 and get back lost functionality other than an up to date ejabberd :')

Actual results:

  ejabberd seems to mess up the software-gui so cant uninstall software or repositories and the gnome-shell toolbar menu only has no suspend or poweroff menu entries so have to 'sudo shutdown' or <control><alt><delete> to do a poweroff/restart


Expected results:

  software-gui should be able to remove software and repos, gnome-shell toolbar menu should have a poweroff or suspend option not just a logout and lock.

Additional info:

  think that when the software-gui is in broken state you can install software without entering admin password ( seem to remember something about this being talked about a while back but not sure if planned or not) but cant uninstall software or remove repositories from list when software-gui is in broken state.
  when software-gui is in fixed state then you are prompted for admin password to add/remove software or repositories.
  if remember right the recent changes to ejabberd involved converting to using systemd/polkit differently so maybe cause is actually ejabberd-0:2.1.13-4.fc19.x86_64 and not a side effect of it in another package?
Comment 1 collura 2013-09-18 07:33:27 EDT
Created attachment 799337 [details]
xsession errors file
Comment 2 collura 2013-09-18 07:34:47 EDT
Created attachment 799338 [details]
Xorg-0-log while new ejabberd installed but dont think rebooted after install...
Comment 3 collura 2013-09-18 07:36:23 EDT
Created attachment 799340 [details]
dmesg with ejabberd installed but dont think rebooted after install....
Comment 4 collura 2013-09-18 07:37:36 EDT
Created attachment 799342 [details]
var log messages of updating of ejabberd
Comment 5 Peter Lemenkov 2013-09-18 07:41:17 EDT
Looks like it possibly could be related to my initial attempt of switching to polkit.
Comment 6 Fedora Update System 2013-10-26 08:30:55 EDT
couchdb-1.3.1-3.fc20, erlang-erlsyslog-0.6.2-4.fc20, erlang-esasl-0.1-13.20120116git665cc80.fc20, erlang-esdl-1.3.1-2.fc20, erlang-js-1.2.2-3.fc20, ejabberd-2.1.13-6.fc20, erlang-R16B-02.3.fc20, wings-1.4.1-8.git9a2473e.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ejabberd-2.1.13-6.fc20,couchdb-1.3.1-3.fc20,wings-1.4.1-8.git9a2473e.fc20,erlang-js-1.2.2-3.fc20,erlang-esdl-1.3.1-2.fc20,erlang-esasl-0.1-13.20120116git665cc80.fc20,erlang-erlsyslog-0.6.2-4.fc20,erlang-R16B-02.3.fc20
Comment 7 Fedora Update System 2013-10-26 08:30:57 EDT
couchdb-1.3.1-3.fc19, erlang-erlsyslog-0.6.2-4.fc19, erlang-esdl-1.3.1-2.fc19, erlang-js-1.2.2-3.fc19, erlang-esasl-0.1-13.20120116git665cc80.fc19, ejabberd-2.1.13-6.fc19, erlang-R16B-02.3.fc19, wings-1.4.1-8.git9a2473e.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ejabberd-2.1.13-6.fc19,couchdb-1.3.1-3.fc19,wings-1.4.1-8.git9a2473e.fc19,erlang-js-1.2.2-3.fc19,erlang-esdl-1.3.1-2.fc19,erlang-esasl-0.1-13.20120116git665cc80.fc19,erlang-erlsyslog-0.6.2-4.fc19,erlang-R16B-02.3.fc19
Comment 8 Peter Lemenkov 2013-10-26 14:33:07 EDT
*** Bug 1023664 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2013-10-26 14:48:36 EDT
Package couchdb-1.3.1-3.fc20, erlang-erlsyslog-0.6.2-4.fc20, erlang-esasl-0.1-13.20120116git665cc80.fc20, erlang-esdl-1.3.1-2.fc20, erlang-js-1.2.2-3.fc20, ejabberd-2.1.13-6.fc20, erlang-R16B-02.3.fc20, wings-1.4.1-8.git9a2473e.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing couchdb-1.3.1-3.fc20 erlang-erlsyslog-0.6.2-4.fc20 erlang-esasl-0.1-13.20120116git665cc80.fc20 erlang-esdl-1.3.1-2.fc20 erlang-js-1.2.2-3.fc20 ejabberd-2.1.13-6.fc20 erlang-R16B-02.3.fc20 wings-1.4.1-8.git9a2473e.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20029/ejabberd-2.1.13-6.fc20,couchdb-1.3.1-3.fc20,wings-1.4.1-8.git9a2473e.fc20,erlang-js-1.2.2-3.fc20,erlang-esdl-1.3.1-2.fc20,erlang-esasl-0.1-13.20120116git665cc80.fc20,erlang-erlsyslog-0.6.2-4.fc20,erlang-R16B-02.3.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-11-06 02:30:49 EST
couchdb-1.3.1-3.fc19, erlang-erlsyslog-0.6.2-4.fc19, erlang-esdl-1.3.1-2.fc19, erlang-js-1.2.2-3.fc19, erlang-esasl-0.1-13.20120116git665cc80.fc19, ejabberd-2.1.13-7.fc19, erlang-R16B-02.3.fc19, wings-1.4.1-8.git9a2473e.fc19, riak-1.3.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-11-10 01:54:26 EST
couchdb-1.3.1-3.fc20, erlang-erlsyslog-0.6.2-4.fc20, erlang-esasl-0.1-13.20120116git665cc80.fc20, erlang-esdl-1.3.1-2.fc20, erlang-js-1.2.2-3.fc20, ejabberd-2.1.13-7.fc20, erlang-R16B-02.3.fc20, wings-1.4.1-8.git9a2473e.fc20, riak-1.3.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.