Bug 1023664 - problem with the polkit rule
problem with the polkit rule
Status: CLOSED DUPLICATE of bug 1009408
Product: Fedora
Classification: Fedora
Component: ejabberd (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-26 14:27 EDT by Fabrice Bellet
Modified: 2013-10-26 14:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-26 14:33:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2013-10-26 14:27:35 EDT
ejabberd-2.1.13-4 from F20 has a problem in its .rules polkit file, from /var/log/secure:

Oct 25 23:30:11 lxorgfr polkitd[578]: /usr/share/polkit-1/rules.d/51-ejabberdctl.rules:2: TypeError: action.lookup(...) is undefined
Oct 25 23:30:11 lxorgfr polkitd[578]: /usr/share/polkit-1/rules.d/51-ejabberdctl.rules:2: TypeError: action.lookup(...) is undefined

according to polkit doc, it is possible to use action.lookup("program") instead of action.lookup("command_line") ?
Comment 1 Peter Lemenkov 2013-10-26 14:33:07 EDT
Fabrice, please wait for a couple of hours and recheck - I've just submitted a new build which should fix that.

*** This bug has been marked as a duplicate of bug 1009408 ***

Note You need to log in before you can comment on or make changes to this bug.