This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 100944 - No login at console possible
No login at console possible
Status: CLOSED CANTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: nss_ldap (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Jay Turner
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-27 15:19 EDT by Dr. Tilmann Bubeck
Modified: 2015-01-07 19:05 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 20:18:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dr. Tilmann Bubeck 2003-07-27 15:19:04 EDT
Description of problem:
Using authconfig to turn User Auththication with LDAP on, results in a system
where nobody is able to login into console login prompts (getty). However, it is
possible to login into gdm in runlevel 5. It is not possible to login as a ldap
user and it is not possible as a local user (/etc/passwd).

LDAP is running on a different server which has not changed since the update of
RH 9.0.93 so I suspect "Severn" as the cause and not the server side.

LDAP for automount is running perfectly. The only problem is user authentication.

I tried to *.* in syslog.conf to get any additional debugging information but I
did not find any message at all, if I try an unsucessful login.



Version-Release number of selected component (if applicable):
207

How reproducible:
Use authconfig to turn on "User Information" and "LDAP Authentication" on.
Boot into runlevel 3
Try to login as root or any other user.

Steps to Reproduce:
1. see above.
2.
3.
    
Actual results:
No login possible

Expected results:
Login

Additional info:
Comment 1 Onno Molenkamp 2003-08-11 17:44:52 EDT
I'm experiencing the same thing. It looks like a bug in the openldap library:
after downgrading both the nss_ldap (because nss_ldap is linked with a static
version of the openldap library) and openldap packages to the RH9 versions,
authentication started working again.

(just having the nss or pam module in the configuration seems to be enough to
make authentication fail, even when they're not actually used because of the
order in which the different modules are processed)
Comment 2 Nalin Dahyabhai 2004-02-09 17:06:11 EST
Can you check /var/log/secure as well?  There should be some record of
an attempt to log in, else I'd suspect that login has been modified
somehow.
Comment 3 Joe Acosta 2005-07-04 14:13:02 EDT
Hi, I'm experiencing a similar problem, only LDAP is NOT turned on.  I upgraded
from FC 3 to FC 4 and am no longer able to login via the console.  

I can login via gdm.  This makes it impossible to go to runlevel 3 or runlevel 1.

I'm using Fedora Core 4.  This bug looks like rh 9?  Not sure if this is the
same issue or related.



Comment 4 Joe Acosta 2005-07-10 18:22:28 EDT
In /etc/pam.d/login I had to comment out the line below and now I can access my
console again.  This could be releated.

#session    required     pam_loginuid.so
Comment 5 Bill Nottingham 2006-08-07 11:55:09 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still running
Red Hat Linux, you are strongly advised to upgrade to a current Fedora Core
release or Red Hat Enterprise Linux or comparable. Some information on which
option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks. Please check if this
issue is still present in a current Fedora Core release. If so, please change
the product and version to match, and check the box indicating that the
requested information has been provided. Note that any bug still open against
Red Hat Linux by the end of 2006 will be closed as 'CANTFIX'. Thanks again for
your help.
Comment 7 Bill Nottingham 2007-07-26 20:18:13 EDT
Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.