Bug 1009513 - [remote-viewer] New display opens in fullscreen
[remote-viewer] New display opens in fullscreen
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jonathon Jongsma
Virtualization Bugs
:
Depends On:
Blocks: 1009648 1022426
  Show dependency treegraph
 
Reported: 2013-09-18 10:56 EDT by Tomas Jamrisko
Modified: 2014-10-14 02:29 EDT (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el6
Doc Type: Bug Fix
Doc Text:
Connecting to a server with --fullscreen=auto-conf, leaving fullscreen and then opening another display results in the second display opening in fullscreen. After this change, the new display will open in window mode after leaving fullscreen, as expected.
Story Points: ---
Clone Of:
: 1022426 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:29:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2013-09-18 10:56:17 EDT
Description of problem:

Connecting to a RHEL6.5 x86 guest with --fullscreen=auto-conf (or from RHEVM with fullscreen enabled), leaving fullscreen and then opening another display results in the second display opening in fullscreen. 

Client had two physical monitors

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-7.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Connect to a guest with fullscreen
2. leave fullscreen
3. Open a second display

Actual results:
The new window gets open in fullscreen
Comment 2 Marc-Andre Lureau 2013-09-21 10:46:05 EDT
What's wrong about that behaviour? What would you expect instead?
Comment 3 Tomas Jamrisko 2013-09-24 06:36:21 EDT
Well, maybe it's just me, but there's usually a reason for leaving fullscreen -> it feels like we're forcing the user to a state he doesn't want to be in. I'd expect the additional open displays to mirror the previous ones (windowed -> windowed, fullscreen -> fullscreen) instead of mixing them.

This obviously needs input from more people...
Comment 4 Marc-Andre Lureau 2013-09-24 06:54:44 EDT
(In reply to Tomas Jamrisko from comment #3)
> Well, maybe it's just me, but there's usually a reason for leaving
> fullscreen -> it feels like we're forcing the user to a state he doesn't
> want to be in. I'd expect the additional open displays to mirror the
> previous ones (windowed -> windowed, fullscreen -> fullscreen) instead of
> mixing them.
> 
> This obviously needs input from more people...

Sorry, I missed you said after "leaving fullscreen". Right, that looks like a bug then.
Comment 5 CongDong 2013-10-23 05:19:10 EDT
I can reproduce this with:
virt-viewer-0.5.6-8.el6.x86_64

Steps to Reproduce:
1. Connect to a guest with fullscreen
2. leave fullscreen
3. Open a second display

Result:
The new window gets open in fullscreen.
Comment 6 Jonathon Jongsma 2013-11-08 11:10:01 EST
Patch sent upstream to fix this: https://www.redhat.com/archives/virt-tools-list/2013-November/msg00028.html
Comment 7 Jonathon Jongsma 2013-11-13 11:12:44 EST
patch applied upstream
Comment 10 zhoujunqin 2014-06-09 05:54:13 EDT
Prepare a client has two physical monitors.

I can reproduce with package: virt-viewer-0.5.6-10.el6.x86_64
with following steps:
1. Connect to a guest with fullscreen
# virt-viewer sound -f
2. leave fullscreen
3. click View---->Display(We can see Display 1 and Display 2 are checked auto.)-----> uncheck Display 2 (only left 1 display).
4. close virt-viewer, and run Step 1 again.
the guest shows with 1 display.
5. leave fullscreen
6. Open a second display (View---->Display----->check Display 2)
Results: the new window (Display 2) gets open in fullscreen.

but when i try to verify this bug with new build: virt-viewer-0.6.0-5.el6.x86_64, met some issue.

After step4, the guest always showing with two display together, so i cannot verify the bug.

So Jonathon Jongsma, is this the expected result, please help me have a look, thanks.
Comment 11 Jonathon Jongsma 2014-06-09 11:51:06 EDT
It is expected that starting virt-viewer with -f will always do auto-conf (enable both displays) in 0.6.0.  To verify this bug, you can simply try to open one additional display (e.g. display 3) and see if that opens in fullscreen.
Comment 12 zhoujunqin 2014-06-12 01:07:41 EDT
Thanks for Jonathon Jongsma's help, i verified with build virt-viewer-0.6.0-5.el6.x86_64 again.

steps:
Prepare a client has two physical monitors.

1. prepare a running guest.
# virsh dominfo sound
Id:             1
Name:           sound
UUID:           31df9b0e-1883-758a-118e-72590803ed12
OS Type:        hvm
State:          running
CPU(s):         1
CPU time:       91.5s
Max memory:     1048576 KiB
Used memory:    1048576 KiB
Persistent:     yes
Autostart:      disable
Managed save:   no
Security model: selinux
Security DOI:   0
Security label: system_u:system_r:svirt_t:s0:c18,c272 (enforcing)

2. setup the environment for open only 1 display when you start in fullscreen.
2.1 close virt-viewer/remote-viewer
2.2 add the following content to file ~/.config/virt-viewer/settings, save and exit.

[31df9b0e-1883-758a-118e-72590803ed12]----->>>UUID of your guest
monitor-mapping=1

3. connect to a guest with fullscreen
# virt-viewer sound -f

4. leave fullscreen 

5. open a second display (View---->Display----->check Display 2)
result: display 2 opens in window mode.
so changed from ON_QA to verified.
Comment 13 errata-xmlrpc 2014-10-14 02:29:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html

Note You need to log in before you can comment on or make changes to this bug.