Bug 1022426 - [remote-viewer] New display opens in fullscreen
[remote-viewer] New display opens in fullscreen
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jonathon Jongsma
Virtualization Bugs
:
Depends On: 1009513 1109400
Blocks: 1009648
  Show dependency treegraph
 
Reported: 2013-10-23 05:24 EDT by CongDong
Modified: 2015-03-05 08:38 EST (History)
9 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el7
Doc Type: Bug Fix
Doc Text:
Connecting to a server with --fullscreen=auto-conf, leaving fullscreen and then opening another display results in the second display opening in fullscreen. After this change, the new display will open in window mode after leaving fullscreen, as expected.
Story Points: ---
Clone Of: 1009513
Environment:
Last Closed: 2015-03-05 08:38:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Jonathon Jongsma 2013-11-13 11:14:08 EST
patch applied upstream.
Comment 4 Jonathon Jongsma 2014-07-07 18:00:48 EDT
will be fixed by rebase
Comment 6 CongDong 2014-07-21 21:38:41 EDT
I can reproduce with: virt-viewer-0.5.7-7.el7.x86_64

VERIFY:
Steps:
Prepare a client has two physical monitors.

1. # virsh start demo
# virsh dominfo demo
Id:             3
Name:           demo
UUID:           4cd561bf-ba7f-404c-9bfa-2651534c56dc
OS Type:        hvm
State:          running
CPU(s):         2
CPU time:       61.2s
Max memory:     1048576 KiB
Used memory:    1048576 KiB
Persistent:     yes
Autostart:      disable
Managed save:   no
Security model: selinux
Security DOI:   0
Security label: system_u:system_r:svirt_t:s0:c246,c937 (enforcing)

2. 
Add following content to ~/.config/virt-viewer/settings
[4cd561bf-ba7f-404c-9bfa-2651534c56dc]
monitor-mapping=1

3. # virt-viewer demo , make sure only 1 display is shown.

4. # virt-viewer demo -f
One display comes out fullscreen.

5. Click "Leave fullscreen" button on the top of virt-viewer
And open another display, "View" -> "Displays" -> "Display 2"

Result:
step5, display 2 comes out in window mode. 

As the result, VERIFIED
Comment 8 errata-xmlrpc 2015-03-05 08:38:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.