Bug 1009636 - AttributeError: 'FC3_Cdrom' object has no attribute 'url'
AttributeError: 'FC3_Cdrom' object has no attribute 'url'
Status: CLOSED DUPLICATE of bug 1004889
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:a166a8680e2e4dcc00f265754a3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 14:55 EDT by Alexander Seleznev
Modified: 2013-09-18 15:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 15:28:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (440.11 KB, text/plain)
2013-09-18 14:55 EDT, Alexander Seleznev
no flags Details
File: anaconda.log (13.66 KB, text/plain)
2013-09-18 14:55 EDT, Alexander Seleznev
no flags Details
File: environ (430 bytes, text/plain)
2013-09-18 14:55 EDT, Alexander Seleznev
no flags Details
File: lsblk_output (1.07 KB, text/plain)
2013-09-18 14:55 EDT, Alexander Seleznev
no flags Details
File: nmcli_dev_list (4.52 KB, text/plain)
2013-09-18 14:55 EDT, Alexander Seleznev
no flags Details
File: os_info (281 bytes, text/plain)
2013-09-18 14:55 EDT, Alexander Seleznev
no flags Details
File: program.log (17.10 KB, text/plain)
2013-09-18 14:55 EDT, Alexander Seleznev
no flags Details
File: storage.log (56.40 KB, text/plain)
2013-09-18 14:55 EDT, Alexander Seleznev
no flags Details
File: syslog (59.19 KB, text/plain)
2013-09-18 14:56 EDT, Alexander Seleznev
no flags Details
File: ifcfg.log (648 bytes, text/plain)
2013-09-18 14:56 EDT, Alexander Seleznev
no flags Details
File: packaging.log (271.93 KB, text/plain)
2013-09-18 14:56 EDT, Alexander Seleznev
no flags Details

  None (edit)
Description Alexander Seleznev 2013-09-18 14:55:18 EDT
Description of problem:


Version-Release number of selected component:
anaconda-20.12-1

The following was filed automatically by anaconda:
anaconda 20.12-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pykickstart/commands/method.py", line 36, in __getattr__
    return getattr(self.handler.cdrom, name)
  File "/usr/lib/python2.7/site-packages/pykickstart/commands/method.py", line 98, in __getattr__
    return FC3_Method.__getattr__(self, name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/iutil.py", line 558, in getdeepattr
    obj = getattr(obj, attr)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/tui/spokes/__init__.py", line 214, in _prep_text
    value = getdeepattr(self.args, entry.attribute)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/tui/spokes/__init__.py", line 246, in refresh
    w = _prep_text(idx+1, entry)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/tui/spokes/source.py", line 236, in refresh
    return EditTUISpoke.refresh(self, args)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 285, in _do_redraw
    input_needed = screen.refresh(args)
AttributeError: 'FC3_Cdrom' object has no attribute 'url'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC5\x20i386 quiet text BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC5
Comment 1 Alexander Seleznev 2013-09-18 14:55:26 EDT
Created attachment 799536 [details]
File: anaconda-tb
Comment 2 Alexander Seleznev 2013-09-18 14:55:30 EDT
Created attachment 799537 [details]
File: anaconda.log
Comment 3 Alexander Seleznev 2013-09-18 14:55:34 EDT
Created attachment 799538 [details]
File: environ
Comment 4 Alexander Seleznev 2013-09-18 14:55:39 EDT
Created attachment 799539 [details]
File: lsblk_output
Comment 5 Alexander Seleznev 2013-09-18 14:55:43 EDT
Created attachment 799540 [details]
File: nmcli_dev_list
Comment 6 Alexander Seleznev 2013-09-18 14:55:48 EDT
Created attachment 799541 [details]
File: os_info
Comment 7 Alexander Seleznev 2013-09-18 14:55:53 EDT
Created attachment 799542 [details]
File: program.log
Comment 8 Alexander Seleznev 2013-09-18 14:55:57 EDT
Created attachment 799543 [details]
File: storage.log
Comment 9 Alexander Seleznev 2013-09-18 14:56:02 EDT
Created attachment 799544 [details]
File: syslog
Comment 10 Alexander Seleznev 2013-09-18 14:56:06 EDT
Created attachment 799545 [details]
File: ifcfg.log
Comment 11 Alexander Seleznev 2013-09-18 14:56:12 EDT
Created attachment 799546 [details]
File: packaging.log
Comment 12 Alexander Seleznev 2013-09-18 15:13:56 EDT
I just tried install Fedora from "Fedora-20-Alpha-TC5-i386-netinst.iso" in text mode and given this error (VirtualBox under F19).

Steps to reproduce:

1. Start install in text mode.
2. Wait...
3. Select "Installation sources".
4. Select "Network".
5. Select "https://".
Comment 13 David Shea 2013-09-18 15:28:57 EDT

*** This bug has been marked as a duplicate of bug 1004889 ***

Note You need to log in before you can comment on or make changes to this bug.