Bug 1004889 - AttributeError: 'FC3_Cdrom' object has no attribute 'noverifyssl'
AttributeError: 'FC3_Cdrom' object has no attribute 'noverifyssl'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:da2f33bcfd2373f8ddb51bce328...
: Reopened
: 1007291 1009636 (view as bug list)
Depends On:
Blocks: F20BetaFreezeException 1011536
  Show dependency treegraph
 
Reported: 2013-09-05 12:55 EDT by Mukundan Ragavan
Modified: 2013-10-18 17:04 EDT (History)
17 users (show)

See Also:
Fixed In Version: pykickstart-1.99.39-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 17:04:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (692.91 KB, text/plain)
2013-09-05 12:55 EDT, Mukundan Ragavan
no flags Details
File: anaconda.log (12.26 KB, text/plain)
2013-09-05 12:55 EDT, Mukundan Ragavan
no flags Details
File: environ (441 bytes, text/plain)
2013-09-05 12:55 EDT, Mukundan Ragavan
no flags Details
File: lsblk_output (1.09 KB, text/plain)
2013-09-05 12:55 EDT, Mukundan Ragavan
no flags Details
File: nmcli_dev_list (4.44 KB, text/plain)
2013-09-05 12:55 EDT, Mukundan Ragavan
no flags Details
File: os_info (281 bytes, text/plain)
2013-09-05 12:55 EDT, Mukundan Ragavan
no flags Details
File: program.log (25.31 KB, text/plain)
2013-09-05 12:56 EDT, Mukundan Ragavan
no flags Details
File: storage.log (52.30 KB, text/plain)
2013-09-05 12:56 EDT, Mukundan Ragavan
no flags Details
File: syslog (59.50 KB, text/plain)
2013-09-05 12:56 EDT, Mukundan Ragavan
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-09-05 12:56 EDT, Mukundan Ragavan
no flags Details
File: packaging.log (450.31 KB, text/plain)
2013-09-05 12:56 EDT, Mukundan Ragavan
no flags Details
anaconda.log (12.84 KB, text/x-log)
2013-10-18 02:41 EDT, lnie
no flags Details
anaconda-tb-* (629.77 KB, text/plain)
2013-10-18 02:42 EDT, lnie
no flags Details
syslog (65.43 KB, text/plain)
2013-10-18 02:43 EDT, lnie
no flags Details
storage.log (51.53 KB, text/x-log)
2013-10-18 02:44 EDT, lnie
no flags Details
packaging.log (349.63 KB, text/x-log)
2013-10-18 02:45 EDT, lnie
no flags Details

  None (edit)
Description Mukundan Ragavan 2013-09-05 12:55:32 EDT
Version-Release number of selected component:
anaconda-20.10-1

The following was filed automatically by anaconda:
anaconda 20.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pykickstart/commands/method.py", line 36, in __getattr__
    return getattr(self.handler.cdrom, name)
  File "/usr/lib/python2.7/site-packages/pykickstart/commands/method.py", line 98, in __getattr__
    return FC3_Method.__getattr__(self, name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 841, in _setupInstallDevice
    sslverify = not (method.noverifyssl or flags.noverifyssl)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 554, in _configureBaseRepo
    url, mirrorlist, sslverify = self._setupInstallDevice(storage, checkmount)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 440, in updateBaseRepo
    self._configureBaseRepo(self.storage, checkmount=checkmount)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 427, in getRepoMetadata
    self.payload.updateBaseRepo(fallback=False, checkmount=False)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'FC3_Cdrom' object has no attribute 'noverifyssl'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC4
Comment 1 Mukundan Ragavan 2013-09-05 12:55:38 EDT
Created attachment 794355 [details]
File: anaconda-tb
Comment 2 Mukundan Ragavan 2013-09-05 12:55:43 EDT
Created attachment 794356 [details]
File: anaconda.log
Comment 3 Mukundan Ragavan 2013-09-05 12:55:46 EDT
Created attachment 794357 [details]
File: environ
Comment 4 Mukundan Ragavan 2013-09-05 12:55:49 EDT
Created attachment 794358 [details]
File: lsblk_output
Comment 5 Mukundan Ragavan 2013-09-05 12:55:56 EDT
Created attachment 794359 [details]
File: nmcli_dev_list
Comment 6 Mukundan Ragavan 2013-09-05 12:55:59 EDT
Created attachment 794360 [details]
File: os_info
Comment 7 Mukundan Ragavan 2013-09-05 12:56:02 EDT
Created attachment 794361 [details]
File: program.log
Comment 8 Mukundan Ragavan 2013-09-05 12:56:05 EDT
Created attachment 794362 [details]
File: storage.log
Comment 9 Mukundan Ragavan 2013-09-05 12:56:09 EDT
Created attachment 794363 [details]
File: syslog
Comment 10 Mukundan Ragavan 2013-09-05 12:56:12 EDT
Created attachment 794364 [details]
File: ifcfg.log
Comment 11 Mukundan Ragavan 2013-09-05 12:56:17 EDT
Created attachment 794365 [details]
File: packaging.log
Comment 12 Mukundan Ragavan 2013-09-05 13:25:21 EDT
I found out what I did to get this crash - tried using a mirrorlist as the installation source.
Comment 13 A.J. Werkman 2013-09-09 08:38:16 EDT
After selecting the http-repo this bug comes up.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:UUID=3cd4da1d-ffdf-4320-afb0-b375dc0d0fb8
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.12-1
product:        Fedora
reason:         AttributeError: 'FC3_Cdrom' object has no attribute 'noverifyssl'
release:        Cannot get release name.
version:        20-Alpha-TC5
Comment 14 Mukundan Ragavan 2013-09-09 09:33:32 EDT
Tried to use mirrorlist in installation source.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC5\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.12-1
product:        Fedora
reason:         AttributeError: 'FC3_Cdrom' object has no attribute 'noverifyssl'
release:        Cannot get release name.
version:        20-Alpha-TC5
Comment 15 Tim Flink 2013-09-11 20:41:44 EDT
Proposing as a blocker for F20 alpha due to possible violation of the following F20 alpha release criterion [1]:

When using the dedicated installer images, the installer must be able to use either HTTP or FTP repositories (or both) as package sources. The network install image must default to a valid publicly-accessible package source.

[1] http://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Remote_package_sources

This isn't a clear-cut violation, though. You can trigger it by entering a http package source url (metalink or striaght mirror) but "closest mirror" doesn't hit it (which is the default on boot.iso)
Comment 16 Tim Flink 2013-09-11 20:44:34 EDT
Proposing as F20 FreezeException as well because even if it's not a blocker, it'd be a good thing to fix for alpha.
Comment 17 Kevin Fenzi 2013-09-11 20:55:00 EDT
+1 FE. would be good to fix.
Comment 18 Jens Petersen 2013-09-11 21:51:15 EDT
According to https://bugzilla.redhat.com/show_bug.cgi?id=1005685#c13
pykickstart-1.99.39-1.fc20 should also fix a backtrace when
trying to set repo source to an URL.  So +1 for FE at least.
Comment 19 Tim Flink 2013-09-11 21:52:04 EDT
That makes +3 FE, moving to accepted.
Comment 20 Jens Petersen 2013-09-11 21:57:19 EDT
I just note here also that pykickstart-1.99.39-1.fc20 is not yet in Bodhi for testing.
Comment 21 lnie 2013-09-11 23:09:15 EDT
still occur in RC1 (x86_64)
Comment 22 Fedora Update System 2013-09-11 23:41:18 EDT
pykickstart-1.99.39-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pykickstart-1.99.39-1.fc20
Comment 23 Petr Schindler 2013-09-12 05:37:49 EDT
It seems to be fixed with pykickstart-1.99.39-1.fc20. RC2 works fine with it.
Comment 24 lnie 2013-09-12 05:47:52 EDT
In RC2 x86_64 (netinst),anaconda keep "Installation source" error checking,if change the source to"http://...".No crash occurs any more,and anaconda is able to do the install if change the source to CD/DVD again.
Comment 25 Fedora Update System 2013-09-17 22:19:58 EDT
pykickstart-1.99.39-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 David Shea 2013-09-18 15:28:57 EDT
*** Bug 1009636 has been marked as a duplicate of this bug. ***
Comment 27 Brian Lane 2013-09-19 17:06:34 EDT
*** Bug 1007291 has been marked as a duplicate of this bug. ***
Comment 28 lnie 2013-10-18 02:11:32 EDT
This bug occured again  in f20 Beta TC5(DVD),
fine with netinst.iso
Comment 29 lnie 2013-10-18 02:41:22 EDT
Created attachment 813620 [details]
anaconda.log
Comment 30 lnie 2013-10-18 02:42:38 EDT
Created attachment 813621 [details]
anaconda-tb-*
Comment 31 lnie 2013-10-18 02:43:40 EDT
Created attachment 813623 [details]
syslog
Comment 32 lnie 2013-10-18 02:44:39 EDT
Created attachment 813625 [details]
storage.log
Comment 33 lnie 2013-10-18 02:45:27 EDT
Created attachment 813626 [details]
packaging.log
Comment 34 Adam Williamson 2013-10-18 15:54:00 EDT
As this was an Alpha FE, if it's recurring, seems logical to propose it as a Beta FE.
Comment 35 Brian Lane 2013-10-18 17:04:20 EDT
You didn't use Beta TC5, it has anaconda 20.25-1 on it and yours has:

anaconda 20.12-1 exception report

Note You need to log in before you can comment on or make changes to this bug.