Bug 100965 - dbus /etc/init.d/messagebus service status reports messagebus dead but pid file exists when service is running
dbus /etc/init.d/messagebus service status reports messagebus dead but pid f...
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: dbus (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: Triaged
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-28 00:00 EDT by Michael Kearey
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 15:40:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Working /etc/init.d/messagebus script (1.64 KB, text/plain)
2003-07-28 00:02 EDT, Michael Kearey
no flags Details

  None (edit)
Description Michael Kearey 2003-07-28 00:00:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030612

Description of problem:
I have found a tiny little problem in an init script for the new 'messagebus'
service.

Even though the daemon called dbus-daemon-1 which is started by the init script
/etc/init.d/messagebus is running, the command 'service messagebus status'
returns 'messagebus dead but pid file exists'.

This is due to a small error in the /etc/init.d/messagebus init script. 
status)
	status messagebus
	RETVAL=$?
	;;

There is no such process as 'messagebus' the process is dbus-daemon-1.
I added line: 

processname=dbus-daemon-1

And changed to :

status)
	status $processname
	RETVAL=$?
	;;
It now reports that the process is running, as it should.

I will add an attatchment of the complete script..

Version-Release number of selected component (if applicable):
dbus-0.11.91-2

How reproducible:
Always

Steps to Reproduce:
1.su to root
2.Start messagebus service 'service messagebus start'
3.Run command 'service messagebus status'
    

Actual Results:  'messagebus dead but pid file exists'.


Expected Results:  dbus-daemon-1 (pid XXXX) is running
Comment 1 Michael Kearey 2003-07-28 00:02:32 EDT
Created attachment 93184 [details]
Working /etc/init.d/messagebus  script

Very simple fix.
Comment 2 Havoc Pennington 2003-07-28 10:05:12 EDT
Applied to CVS, needs to be built in RPM form. Thanks.
Comment 3 Miloslav Trmac 2003-10-18 09:55:53 EDT
Fix confirmed.

Note You need to log in before you can comment on or make changes to this bug.