Bug 10097 - Disk devices are not assigned in proper order
Disk devices are not assigned in proper order
Status: CLOSED DUPLICATE of bug 6772
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-09 14:28 EST by yencheng kang
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-09 14:50:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yencheng kang 2000-03-09 14:28:06 EST
I am not sure this is raidtools problem. I believe this is the problem in
the installation program of the Red Hat 6.1.

I am using Dell PowerEdge 2300/400 with 2 internal drives (8 GB) and 1
external raid tower that has 4 disk drives and configured as RAID5 (17 GB).
When I installed the Red Hat 6.1, it shows the devices as follows:

    sda        17GB (external drives)
    sdb         8GB (internal drive)
    sdc         8GB (internal drive)

The actual order of devices after the boot are:

    sda         8GB (internal drive)
    sdb         8GB (internal drive)
    sdc        17GB (external drives)

The partion devices are also re-arranged in the decending order of the
partition size when a new partition is created during the installation.


This cause the problem when I create raid devices (software raid - RAID1)
from the internal drives.
Comment 1 Bill Nottingham 2000-03-09 14:50:59 EST
*** This bug has been marked as a duplicate of 6772 ***

Note You need to log in before you can comment on or make changes to this bug.