Bug 100971 - Sound does not get loaded automatically
Sound does not get loaded automatically
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: initscripts (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 100973 100974 100985 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-28 04:55 EDT by Need Real Name
Modified: 2014-03-16 22:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-22 15:53:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-07-28 04:55:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
This is a problem going back to at least RH 7.3 and sound-configuration.

I have a cs4237 based card which is recognised and always loads when you type 
modprobe cs4232, however it does not load on boot.

The reason is that in /etc/rc.d/rc.sysinit the sound modules initialisation 
string checks for the line
options sound dmabuf=1 
in /etc/modules.conf which is not setup by kudzu etc

So adding this line in /etc/moudules.conf or amending /etc/rc.sysinit makes 
sound load on bootup.

I dont know how many sound cards this affects, but certainly is a problem with 
mine (which is a isa pnp)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See description
    

Actual Results:  See description

Expected Results:  See description

Additional info:
Comment 1 Need Real Name 2003-07-28 12:02:49 EDT
*** Bug 100973 has been marked as a duplicate of this bug. ***
Comment 2 Need Real Name 2003-07-28 12:03:22 EDT
*** Bug 100974 has been marked as a duplicate of this bug. ***
Comment 3 Need Real Name 2003-07-28 12:03:57 EDT
*** Bug 100985 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2003-07-28 12:06:18 EDT
How does sound not loading automatically cause problems?
Comment 5 Miloslav Trmac 2003-07-28 13:52:27 EDT
The driver might not be able to allocate enough memory accessible via ISA
DMA.
Comment 6 Bill Nottingham 2003-07-28 14:25:23 EDT
Without the option mentioned, it won't statically allocate it anyway, so in the
case where the option is not there, loading it early won't help.
Comment 7 Bill Nottingham 2005-02-22 15:53:30 EST
Closing out bugs on older, no longer supported releases. Apologies for any lack
of response. Please reopen if it persists on current releases.

Note You need to log in before you can comment on or make changes to this bug.