Bug 1009966 - Published repositories are missing errata severity in generated *-updateinfo.xml
Published repositories are missing errata severity in generated *-updateinfo.xml
Status: CLOSED WORKSFORME
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: pulp-bugs
pulp-qe-list
:
Depends On:
Blocks: 950743
  Show dependency treegraph
 
Reported: 2013-09-19 11:32 EDT by Brad Buckingham
Modified: 2013-09-25 10:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-25 10:22:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2013-09-19 11:32:10 EDT
Description of problem:

Published repositories do not include errata severity from the source repository.

Version-Release number of selected component (if applicable):

pulp-server-2.2.0-0.22.beta.el6.noarch

How reproducible:
always (Observed both with zoo test and RHEL repos)

Steps to Reproduce:
1. create/sync/publish a repo (e.g. using feed url: 
   http://inecas.fedorapeople.org/fakerepos/new_cds/content/zoo/1.1/x86_64/rpms)

2. observe that the ./repodata/*.updateinfo.xml.gz from the feed includes a severity element.  For example:
  <severity>Critical</severity>

Actual results:

The *-updateinfo.xml in the published repo (under /var/lib/pulp/published) does not include the severity from the source.

Expected results:

The *-updateinfo.xml in the published repo should include the severity and APIs to retrieve errata information should include it.

Additional info:
Comment 1 Michael Hrivnak 2013-09-25 10:22:45 EDT
I followed these steps with pulp 2.2 stable on RHEL6 with the zoo repo noted. Severity was included in the published repo, so I am not able to reproduce this.

Please re-open if you can reproduce on 2.2 stable or newer.

Note You need to log in before you can comment on or make changes to this bug.