Bug 1010048 - Exception is raised and logged after DTGov runtime is installed until a workflow is deployed
Exception is raised and logged after DTGov runtime is installed until a workf...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Kurt T Stam
Stefan Bunciak
:
: 1010822 1016653 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 15:25 EDT by Len DiMaggio
Modified: 2014-03-05 10:46 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log (252.21 KB, text/plain)
2013-09-19 15:28 EDT, Len DiMaggio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DTGOV-91 Major Closed Exception is raised and logged after DTGov runtime is installed until a workflow is deployed 2014-09-08 03:47:57 EDT

  None (edit)
Description Len DiMaggio 2013-09-19 15:25:18 EDT
Description of problem:

Exception is raised and logged after DTGov runtime is installed until a workflow is deployed:

13:40:48,245 ERROR [org.jboss.msc.service.fail] (ServerService Thread Pool -- 61) MSC000001: Failed to start service jboss.deployment.unit."overlord-rtgov-acs.war".component.JEEACSLoader.START: org.jboss.msc.service.StartException in service jboss.deployment.unit."overlord-rtgov-acs.war".component.JEEACSLoader.START: java.lang.IllegalStateException: JBAS011048: Failed to construct component instance
13:41:42,714 ERROR [org.overlord.dtgov.jbpm.util.ApplicationScopedProducer] (ServerService Thread Pool -- 64) Could not find or read the SRAMPPackage
13:41:42,715 ERROR [org.overlord.dtgov.jbpm.util.ApplicationScopedProducer] (ServerService Thread Pool -- 64) Cannot find KieModule: org.overlord.dtgov:dtgov-workflows:1.0.1.Final-redhat-3: java.lang.RuntimeException: Cannot find KieModule: org.overlord.dtgov:dtgov-workflows:1.0.1.Final-redhat-3
1

Version-Release number of selected component (if applicable):
ER3

How reproducible:
100%

Steps to Reproduce:
1. Install the FSW server and DTGov runtime - start the server before deploying a workflow
2.
3.

Actual results:

The above exception/ERROR

Expected results:
If we cannot get rid of the exception, can we at least change this to an INFO/WARN message?

Additional info:

See attached server.log
Comment 1 Len DiMaggio 2013-09-19 15:28:14 EDT
Created attachment 800110 [details]
Server log
Comment 2 Len DiMaggio 2013-09-24 11:08:58 EDT
*** Bug 1010822 has been marked as a duplicate of this bug. ***
Comment 7 Pavol Srna 2013-10-08 09:31:13 EDT
*** Bug 1016653 has been marked as a duplicate of this bug. ***
Comment 8 Kurt T Stam 2013-10-08 10:02:39 EDT
Are you sure the workflow is deployed? I think you will need to run something
like mvn deploy (not install?) and making sure the srampWagon is invoked.
Comment 9 Kurt T Stam 2013-10-08 10:04:17 EDT
(In reply to Kurt T Stam from comment #8)
> Are you sure the workflow is deployed? I think you will need to run something
> like mvn deploy (not install?) and making sure the srampWagon is invoked.

Ignore comment; wrong bz
Comment 10 Kurt T Stam 2013-10-08 10:15:30 EDT
We cannot change the logging; this is coming from jBPM. Anyway  - working on the real fix for this; which is to manage the kie packages.
Comment 11 JBoss JIRA Server 2013-10-11 15:44:52 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-91 to Resolved
Comment 12 JBoss JIRA Server 2013-10-11 15:44:58 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-91 to Closed
Comment 13 Stefan Bunciak 2013-12-12 09:01:13 EST
Verified in FSW 6.0.0.ER7
Comment 14 JBoss JIRA Server 2014-03-05 10:40:56 EST
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-91 to Reopened
Comment 15 JBoss JIRA Server 2014-03-05 10:46:12 EST
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-91 to Closed

Note You need to log in before you can comment on or make changes to this bug.