Bug 101015 - httpd.conf needs to be modified due to changes in httpd manual
httpd.conf needs to be modified due to changes in httpd manual
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: httpd (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-28 11:55 EDT by Need Real Name
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version: 2.0.47-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 17:33:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-07-28 11:55:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.2.1) Gecko/20030225

Description of problem:
Hi people:
I'm testing the httpd rawhide release, since httpd-2.0.47 the httpd manual has
changed a bit so the httpd.conf file needs to be modified in a way the manual
works, here a patch that fix this to the httpd.conf of the source of srpm...

--- httpd.conf-orig	2003-05-18 14:37:22.000000000 -0400
+++ httpd.conf	2003-07-28 11:11:14.000000000 -0400
@@ -562,13 +562,25 @@
 # the manual, even if you choose to move your DocumentRoot.  You may comment
 # this out if you do not care for the documentation.
 #
-Alias /manual "/var/www/manual"
+AliasMatch ^/manual(?:/(?:de|en|fr|ja|ko|ru))?(/.*)?$ "/var/www/manual$1"
 
 <Directory "/var/www/manual">
-    Options Indexes FollowSymLinks MultiViews
+    Options Indexes
     AllowOverride None
     Order allow,deny
     Allow from all
+
+    <Files *.html>
+        SetHandler type-map
+    </Files>
+
+    SetEnvIf Request_URI ^/manual/de/ prefer-language=de
+    SetEnvIf Request_URI ^/manual/en/ prefer-language=en
+    SetEnvIf Request_URI ^/manual/fr/ prefer-language=fr
+    SetEnvIf Request_URI ^/manual/ja/ prefer-language=ja
+    SetEnvIf Request_URI ^/manual/ko/ prefer-language=ko
+    SetEnvIf Request_URI ^/manual/ru/ prefer-language=ru
+    RedirectMatch 301 ^/manual(?:/(de|en|fr|ja|ko|ru)){2,}(/.*)?$ /manual/$1$2
 </Directory>
 
 <IfModule mod_dav_fs.c>

Version-Release number of selected component (if applicable):
httpd-2.0.47-3

How reproducible:
Always

Steps to Reproduce:
1.Install the httpd-manual
2.
3.
    

Actual Results:  The manual don't display correctly the html pages

Additional info:
Comment 1 Pekka Savola 2003-08-07 08:23:36 EDT
Is this in the httpd upstream config file?  If not, please push it there first?
Comment 2 Joe Orton 2003-08-29 10:35:53 EDT
Yes that fragment is from the upstream config IIRC.
Comment 3 Joe Orton 2003-09-08 11:22:30 EDT
Thanks for the report and patch, applied in 2.0.47-6.

Note You need to log in before you can comment on or make changes to this bug.