Bug 1010239 - nfs: nfs process crash when nfstest_posix tool is run.
nfs: nfs process crash when nfstest_posix tool is run.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Raghavendra G
Saurabh
: ZStream
Depends On:
Blocks: 1010241 1196898
  Show dependency treegraph
 
Reported: 2013-09-20 06:51 EDT by Saurabh
Modified: 2016-01-19 01:13 EST (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.39rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1010241 (view as bug list)
Environment:
Last Closed: 2013-11-27 10:40:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-09-20 06:51:35 EDT
Description of problem:

executed the tool nfstest_posix tool

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.33rhs-1.el6rhs

How reproducible:
always

Steps to Reproduce:
1. execute nfstest-posix testsuite.
2.
3.

Actual results:

patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 2013-09-20 10:13:38configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.4.0.33rhs
/lib64/libc.so.6[0x3cdd832960]
/usr/lib64/glusterfs/3.4.0.33rhs/xlator/nfs/server.so(nfs3_stat_to_fattr3+0x28)[0x7f56114568f8]
/usr/lib64/glusterfs/3.4.0.33rhs/xlator/nfs/server.so(nfs3_fill_getattr3res+0x35)[0x7f5611456b25]
/usr/lib64/glusterfs/3.4.0.33rhs/xlator/nfs/server.so(nfs3_getattr_reply+0x3a)[0x7f561144494a]
/usr/lib64/glusterfs/3.4.0.33rhs/xlator/nfs/server.so(nfs3svc_getattr_stat_cbk+0x4d)[0x7f561144776d]
/usr/lib64/glusterfs/3.4.0.33rhs/xlator/nfs/server.so(nfs_fop_stat_cbk+0x41)[0x7f561143bc91]
/usr/lib64/glusterfs/3.4.0.33rhs/xlator/debug/io-stats.so(io_stats_stat_cbk+0xf6)[0x7f56118f7196]
/usr/lib64/libglusterfs.so.0(default_stat_cbk+0xc2)[0x3981426742]
/usr/lib64/glusterfs/3.4.0.33rhs/xlator/cluster/distribute.so(dht_attr2+0x234)[0x7f5611d438a4]
/usr/lib64/glusterfs/3.4.0.33rhs/xlator/cluster/distribute.so(+0xb196)[0x7f5611d1a196]
/usr/lib64/libglusterfs.so.0(synctask_wrap+0x2a)[0x398144983a]
/lib64/libc.so.6[0x3cdd843bb0]
---------

Expected results:
crash is not expected

Additional info:
Comment 2 santosh pradhan 2013-11-04 00:51:19 EST
*** Bug 1025604 has been marked as a duplicate of this bug. ***
Comment 3 santosh pradhan 2013-11-04 02:35:16 EST
Posted the NFS side FIX for review (upstream)
http://review.gluster.org/#/c/6026/

DHT fix is being worked by Raghavendra Gowdappa.
Comment 4 Saurabh 2013-11-11 00:56:33 EST
executed the same test and crash is not seen anymore.

verified on glusterfs-3.4.0.40rhs-1
Comment 5 errata-xmlrpc 2013-11-27 10:40:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.