Bug 101040 - Massive oops & filesystem corruption on AMD Athlon
Massive oops & filesystem corruption on AMD Athlon
Status: CLOSED DUPLICATE of bug 99507
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
athlon Linux
high Severity high
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
Depends On:
Blocks: 97942
  Show dependency treegraph
Reported: 2003-07-28 15:09 EDT by Felipe Alfaro Solana
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:57:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output of the "dmesg" command (15.12 KB, text/plain)
2003-07-28 15:10 EDT, Felipe Alfaro Solana
no flags Details
output of the "lspci -vvv" command (7.26 KB, text/plain)
2003-07-28 15:11 EDT, Felipe Alfaro Solana
no flags Details
output of "cat /proc/interrupts" (425 bytes, text/plain)
2003-07-28 15:11 EDT, Felipe Alfaro Solana
no flags Details
output of "cat /proc/ioports" (929 bytes, text/plain)
2003-07-28 15:12 EDT, Felipe Alfaro Solana
no flags Details

  None (edit)
Description Felipe Alfaro Solana 2003-07-28 15:09:31 EDT
Description of problem: 
After installing Taroon Beta 1 on my AMD Athlon Compaq Presario laptop, I 
booted it up and found a lot of oopses during boot. The kernel is oopsing at 
"do_generic_file_read" at a very fast rate which overflows the "dmesg" kernel ring 
I have attached to thig bug report the output of "dmesg", plus "lspci" and a copy of 
"/proc/ioports" and "/proc/interrupts". 
Version-Release number of selected component (if applicable): 
Stock Red Hat Linux Taroon Beta 1 kernel. 
How reproducible: 
Steps to Reproduce: 
1. Install Taroon AS Beta 1 on a Compaq Presario 706EA, or a similar computer, 
since I don't know if this problem is related to hardware configuration. 
2. Choose to install "Everything" 
3. After installation and upon rebooting, the kernel starts oopsing. The result of 
the "dmesg" command after booting into runlevel 1 is attached in the bug report. 
Actual results: 
The system oopses continuously and ends up corrupting the filesystem, requiring 
a full system reinstall. 
Expected results: 
The system should be stable with the selected hardware configuration. At least, 
Red Hat Linux Beta is completely stable on the same machine. 
Additional info: 
The problem is reproducible with either ext2 or ext3 filesystems. 
The machine used to install RHL AS is a Compaq Presario 706EA.
Comment 1 Felipe Alfaro Solana 2003-07-28 15:10:37 EDT
Created attachment 93190 [details]
output of the "dmesg" command

The kernel oopses at a very fast rate, and thus, I've been unable to capture
the full kernel ring as it overflows.
Comment 2 Felipe Alfaro Solana 2003-07-28 15:11:04 EDT
Created attachment 93191 [details]
output of the "lspci -vvv" command
Comment 3 Felipe Alfaro Solana 2003-07-28 15:11:42 EDT
Created attachment 93192 [details]
output of "cat /proc/interrupts"
Comment 4 Felipe Alfaro Solana 2003-07-28 15:12:10 EDT
Created attachment 93193 [details]
output of "cat /proc/ioports"
Comment 5 Ernie Petrides 2003-07-29 14:10:51 EDT
Thank you for your detailed bug report.  Red Hat is aware of this
problem, and several options for fixing it are currently under
review.  The original bug report is #99507.

*** This bug has been marked as a duplicate of 99507 ***
Comment 6 Bill Nottingham 2003-08-01 15:16:02 EDT
*** Bug 101481 has been marked as a duplicate of this bug. ***
Comment 7 Nitin Dahyabhai 2003-08-05 22:42:38 EDT
I can't see bug 99507, but I'm getting the same problem on an untainted NForce2
based platform.
Comment 8 Ernie Petrides 2003-08-06 23:58:49 EDT
Nitin, I didn't want to add your "outside" e-mail address to the
cc: list of bug #99507 (which is restricted to beta partners), so
here is a copy of my final comment for 99507 posted on 2003-07-31:

This problem is believed to be caused by a flaw in the Athlon XP
cpu, which under unusual circumstances, allows a "prefetch" machine
instruction with certain alignments and/or cache conflicts to cause
a page fault on address 0 (in violation of the instruction's
functional description).

A work-around has been committed to Taroon today to the Athlon-specific
prefetch routine to test for NULL addresses.  The change is applied by
linux-2.4.18-smallpatches.patch to include/asm-i386/processor.h, and
will be incorporated into any kernel version 2.4.21-1.1931.2.364 or
later (and will thus be part of Taroon B2).
Comment 9 Red Hat Bugzilla 2006-02-21 13:57:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.