Bug 1010441 - AttributeError: 'NoneType' object has no attribute 'id'
AttributeError: 'NoneType' object has no attribute 'id'
Status: CLOSED DUPLICATE of bug 1004572
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
ppc64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:819710cc56fe7dfc6855555006d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 15:16 EDT by Mark Hamzy
Modified: 2013-09-20 15:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 15:26:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (36.55 KB, text/plain)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details
File: environ (549 bytes, text/plain)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details
File: lsblk_output (1.89 KB, text/plain)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details
File: nmcli_dev_list (5.89 KB, text/plain)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details
File: program.log (42.38 KB, text/plain)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details
File: storage.log (280.39 KB, text/plain)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details
File: syslog (50.54 KB, text/plain)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details
File: ifcfg.log (1.44 KB, text/plain)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details
File: packaging.log (608.21 KB, text/plain)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details
File: anaconda-tb (1.03 MB, application/octet-stream)
2013-09-20 15:17 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2013-09-20 15:16:57 EDT
Description of problem:
Trying to modify the volume group properties to be RAID5

Version-Release number of selected component:
anaconda-20.18-1

The following was filed automatically by anaconda:
anaconda 20.18-1 exception report
Traceback (most recent call first):
  File "/tmp/updates/blivet/__init__.py", line 1948, in copy
    root.swaps = [new.devicetree.getDeviceByID(d.id) for d in root.swaps]
  File "/tmp/updates/blivet/devicefactory.py", line 767, in _save_devicetree
    _blivet_copy = self.storage.copy()
  File "/tmp/updates/blivet/devicefactory.py", line 704, in configure
    self._save_devicetree()
  File "/tmp/updates/blivet/__init__.py", line 1924, in factoryDevice
    factory.configure()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1069, in _replace_device
    new_device = self.__storage.factoryDevice(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1362, in _save_right_side
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2400, in _save_current_selector
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2411, in on_selector_clicked
    self._save_current_selector()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 216, in _onSelectorClicked
    cb(selector)
AttributeError: 'NoneType' object has no attribute 'id'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/ppc/ppc64/vmlinuz ro inst.vnc inst.sshd ip=9.5.114.36::9.5.114.1:255.255.255.0:sharpie.rch.stglabs.ibm.com:eth0:none nameserver=9.10.244.100 bootdev=eth0 live.updates=http://chukar.rch.stglabs.ibm.com/updates-ppc64le.img
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.ppc64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20
Comment 1 Mark Hamzy 2013-09-20 15:17:02 EDT
Created attachment 800637 [details]
File: anaconda.log
Comment 2 Mark Hamzy 2013-09-20 15:17:05 EDT
Created attachment 800638 [details]
File: environ
Comment 3 Mark Hamzy 2013-09-20 15:17:09 EDT
Created attachment 800639 [details]
File: lsblk_output
Comment 4 Mark Hamzy 2013-09-20 15:17:12 EDT
Created attachment 800640 [details]
File: nmcli_dev_list
Comment 5 Mark Hamzy 2013-09-20 15:17:16 EDT
Created attachment 800641 [details]
File: os_info
Comment 6 Mark Hamzy 2013-09-20 15:17:20 EDT
Created attachment 800642 [details]
File: program.log
Comment 7 Mark Hamzy 2013-09-20 15:17:24 EDT
Created attachment 800643 [details]
File: storage.log
Comment 8 Mark Hamzy 2013-09-20 15:17:28 EDT
Created attachment 800644 [details]
File: syslog
Comment 9 Mark Hamzy 2013-09-20 15:17:32 EDT
Created attachment 800646 [details]
File: ifcfg.log
Comment 10 Mark Hamzy 2013-09-20 15:17:36 EDT
Created attachment 800647 [details]
File: packaging.log
Comment 11 Mark Hamzy 2013-09-20 15:17:41 EDT
Created attachment 800648 [details]
File: anaconda-tb
Comment 12 David Lehman 2013-09-20 15:26:38 EDT

*** This bug has been marked as a duplicate of bug 1004572 ***

Note You need to log in before you can comment on or make changes to this bug.