Bug 1010489 - TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'
TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'
Status: CLOSED DUPLICATE of bug 1005506
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:3261f9ac6dd9a246e837f04bffd...
:
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-09-20 17:04 EDT by Chris Murphy
Modified: 2013-09-21 08:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-21 08:31:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (11.92 KB, text/plain)
2013-09-20 17:04 EDT, Chris Murphy
no flags Details
File: environ (439 bytes, text/plain)
2013-09-20 17:04 EDT, Chris Murphy
no flags Details
File: lsblk_output (2.35 KB, text/plain)
2013-09-20 17:04 EDT, Chris Murphy
no flags Details
File: nmcli_dev_list (4.44 KB, text/plain)
2013-09-20 17:04 EDT, Chris Murphy
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-20 17:04 EDT, Chris Murphy
no flags Details
File: program.log (25.24 KB, text/plain)
2013-09-20 17:04 EDT, Chris Murphy
no flags Details
File: storage.log (127.73 KB, text/plain)
2013-09-20 17:04 EDT, Chris Murphy
no flags Details
File: syslog (190.36 KB, text/plain)
2013-09-20 17:04 EDT, Chris Murphy
no flags Details
File: ifcfg.log (1.86 KB, text/plain)
2013-09-20 17:04 EDT, Chris Murphy
no flags Details
File: packaging.log (924.21 KB, text/plain)
2013-09-20 17:05 EDT, Chris Murphy
no flags Details
File: anaconda-tb (1.30 MB, application/octet-stream)
2013-09-20 17:05 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-09-20 17:04:21 EDT
Description of problem:
Autopartitioning. Specified thin provisioning partition type. In the main spoke the status was waiting while saving storage selection, then crashed.

Version-Release number of selected component:
anaconda-20.18-1

The following was filed automatically by anaconda:
anaconda 20.18-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2615, in vgSpaceUsed
    + self.logSize + self.metaDataSize)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2847, in vgSpaceUsed
    space = super(LVMThinPoolDevice, self).vgSpaceUsed
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2409, in <genexpr>
    used = sum(lv.vgSpaceUsed for lv in self.lvs) + self.snapshotSpace
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2409, in freeSpace
    used = sum(lv.vgSpaceUsed for lv in self.lvs) + self.snapshotSpace
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2296, in _addLogVol
    lv.size > self.freeSpace:
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2564, in __init__
    self.parents[0]._addLogVol(self)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1144, in newLV
    return device_class(name, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 282, in _scheduleVolumes
    dev = new_volume(**kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 321, in doAutoPartition
    _scheduleVolumes(storage, devs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 244, in execute
    doAutoPartition(storage, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1678, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 420, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: unsupported operand type(s) for +: 'long' and 'NoneType'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha
Comment 1 Chris Murphy 2013-09-20 17:04:26 EDT
Created attachment 800735 [details]
File: anaconda.log
Comment 2 Chris Murphy 2013-09-20 17:04:29 EDT
Created attachment 800736 [details]
File: environ
Comment 3 Chris Murphy 2013-09-20 17:04:33 EDT
Created attachment 800737 [details]
File: lsblk_output
Comment 4 Chris Murphy 2013-09-20 17:04:36 EDT
Created attachment 800738 [details]
File: nmcli_dev_list
Comment 5 Chris Murphy 2013-09-20 17:04:39 EDT
Created attachment 800739 [details]
File: os_info
Comment 6 Chris Murphy 2013-09-20 17:04:43 EDT
Created attachment 800740 [details]
File: program.log
Comment 7 Chris Murphy 2013-09-20 17:04:46 EDT
Created attachment 800741 [details]
File: storage.log
Comment 8 Chris Murphy 2013-09-20 17:04:52 EDT
Created attachment 800742 [details]
File: syslog
Comment 9 Chris Murphy 2013-09-20 17:04:55 EDT
Created attachment 800743 [details]
File: ifcfg.log
Comment 10 Chris Murphy 2013-09-20 17:05:00 EDT
Created attachment 800744 [details]
File: packaging.log
Comment 11 Chris Murphy 2013-09-20 17:05:06 EDT
Created attachment 800745 [details]
File: anaconda-tb
Comment 12 Chris Murphy 2013-09-20 18:01:10 EDT
This is reproducible on baremetal and in a VM. Proposing as beta blocker: using guided partitioning flow, the installer must be able to reject or disallow invalid disk and volume configurations without crashing.
Comment 13 David Shea 2013-09-21 08:31:55 EDT

*** This bug has been marked as a duplicate of bug 1005506 ***

Note You need to log in before you can comment on or make changes to this bug.