Bug 1010532 - SystemDUnitUnknownTypeWarning
SystemDUnitUnknownTypeWarning
Status: CLOSED DUPLICATE of bug 1236419
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-21 05:19 EDT by orti1980
Modified: 2015-06-29 12:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 12:15:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description orti1980 2013-09-21 05:19:39 EDT
Sep 21 11:17:43 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'system.slice' is of unknown type 'slice'
Sep 21 11:17:43 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Sep 21 11:17:43 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'system-getty.slice' is of unknown type 'slice'
Sep 21 11:17:43 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Sep 21 11:17:43 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'system-serial\x2dgetty.slice' is of unknown type 'slice'
Sep 21 11:17:43 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Sep 21 11:17:43 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'user.slice' is of unknown type 'slice'
Sep 21 11:17:43 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Sep 21 11:17:43 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id '-.slice' is of unknown type 'slice'
Sep 21 11:17:43 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Sep 21 11:17:43 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'system-systemd\x2dfsck.slice' is of unknown type 'slice'
Sep 21 11:17:43 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Sep 21 11:17:43 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'user-1000.slice' is of unknown type 'slice'
Sep 21 11:17:43 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Sep 21 11:17:43 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'session-1.scope' is of unknown type 'scope'
Sep 21 11:17:43 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Sep 21 11:17:43 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'user-0.slice' is of unknown type 'slice'
Sep 21 11:17:43 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Sep 21 11:17:43 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'session-2.scope' is of unknown type 'scope'
Sep 21 11:17:43 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Sep 21 11:17:48 localhost systemd-logind: New session 12 of user root.
Sep 21 11:17:48 localhost systemd: Starting Session 12 of user root.
Sep 21 11:17:48 localhost systemd: Started Session 12 of user root.
Sep 21 11:17:48 localhost dbus-daemon: /usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'session-12.scope' is of unknown type 'scope'
Sep 21 11:17:48 localhost dbus-daemon: new_unit = SystemDUnit(self, unit_id, unit_path)
Comment 1 Lennart Poettering 2013-09-27 11:45:59 EDT
Those messages are actually generated by systemd-config-services. Reassigning.
Comment 2 orti1980 2013-09-27 14:03:41 EDT
[root@localhost js]# system-config-services
Couldn't acquire connection to systemd. Falling back to legacy SysV scheme.
Traceback (most recent call last):
  File "/bin/system-config-services", line 49, in <module>
    UIController(use_dbus=use_dbus).run()
  File "/usr/lib/python2.7/site-packages/scservices/gui/__init__.py", line 1230, in __init__
    self.serviceherders.append(cls(bus=self._bus))
  File "/usr/lib/python2.7/site-packages/scservices/dbus/proxy/serviceherders.py", line 62, in __init__
    for service_name in self.list_services():
  File "<string>", line 2, in list_services
  File "/usr/lib/python2.7/site-packages/slip/dbus/polkit.py", line 103, in _enable_proxy
    return func(*p, **k)
  File "/usr/lib/python2.7/site-packages/scservices/dbus/proxy/serviceherders.py", line 74, in list_services
    return self.herder_interface.list_services()
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/slip/dbus/proxies.py", line 50, in __call__
    return dbus.proxies._ProxyMethod.__call__(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "list_services" with signature "" on interface "org.fedoraproject.Config.Services.ServiceHerder" doesn't exist
Comment 3 Jaroslav Reznik 2015-03-03 10:05:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 4 Nils Philippsen 2015-06-29 12:15:03 EDT
(In reply to orti1980 from comment #2)
> [root@localhost js]# system-config-services
> Couldn't acquire connection to systemd. Falling back to legacy SysV scheme.

This is actually a different issue, please file a separate bug if the problem still persists, along with a description what you did, how to reproduce it -- it shouldn't really happen that you can't connect to systemd on the system bus.

That s-c-services doesn't know about certain types of units is the same as bug #1236419.

*** This bug has been marked as a duplicate of bug 1236419 ***

Note You need to log in before you can comment on or make changes to this bug.