Bug 1236419 - Failure accessing DBUS: Type 'busname' is unknown.
Summary: Failure accessing DBUS: Type 'busname' is unknown.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-services
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1010532 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-28 20:19 UTC by Peter Trenholme
Modified: 2015-07-13 19:19 UTC (History)
2 users (show)

Fixed In Version: system-config-services-0.111.4-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-13 19:07:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Trenholme 2015-06-28 20:19:31 UTC
Description of problem: Starting system-config-services from a terminal produces several error messages.

Version-Release number of selected component (if applicable): rawhide latest

How reproducible: Every time

Steps to Reproduce: Invoke system-config-services from a terminal

Actual results: See below

Expected results: No error messages

Additional info: This may, of course, be a bus problem.

Anyhow, here's what I see. (And the service configuration system works "strangely."):

$ system-config-services
/usr/lib/python2.7/site-packages/scservices/gui/__init__.py:1009: Warning: The property GtkDialog:has-separator is deprecated and shouldn't be used anymore. It will be removed in a future version.
  domain=config.domain)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.fedoraproject.FirewallD1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.systemd1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.Avahi.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.bluez.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.resolve1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.ColorManager.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.locale1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.hostname1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.ConsoleKit.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.Accounts.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.RealtimeKit1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'fi.w1.wpa_supplicant1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.machine1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.network1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.PolicyKit1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.NetworkManager.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.UDisks2.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.UPower.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.problems.daemon.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.import1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.ModemManager1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.login1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)
/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py:101: SystemDUnitUnknownTypeWarning: Unit id 'org.freedesktop.timedate1.busname' is of unknown type 'busname'
  new_unit = SystemDUnit(self, unit_id, unit_path)

Comment 1 Nils Philippsen 2015-06-29 16:15:03 UTC
*** Bug 1010532 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2015-06-29 19:58:13 UTC
system-config-services-0.111.4-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/system-config-services-0.111.4-1.fc22

Comment 3 Fedora Update System 2015-06-29 19:58:20 UTC
system-config-services-0.111.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/system-config-services-0.111.4-1.fc21

Comment 4 Fedora Update System 2015-06-30 20:14:07 UTC
Package system-config-services-0.111.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-services-0.111.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10957/system-config-services-0.111.4-1.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-07-13 19:07:29 UTC
system-config-services-0.111.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2015-07-13 19:19:33 UTC
system-config-services-0.111.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.