Bug 101073 - kernel configuration section fails to load
kernel configuration section fails to load
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kdebase (Show other bugs)
AS-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-28 17:45 EDT by Elton Woo
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 09:31:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2003-07-28 17:45:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Kernel configuration panel fails to load with the following error 
message:

"Sorry

The kernel configuration could not be read due to the following error: 

/usr/src/linux-2.4/drivers/net/wan/Config.in, line 84 "

Version-Release number of selected component (if applicable):
kdebase-3.1.2-13, kdelibs-3.1.2-7

How reproducible:
Always

Steps to Reproduce:
1.Start KDE Control Center
2. Select kernel configuration section
3.
    

Actual Results:  error message pops up, and further action in that
section is disabled.

Expected Results:  section should startup and request / provide root access,
then su- user can configure the kernel options,

Additional info:
Comment 1 Elton Woo 2003-07-28 17:46:30 EDT
Severn beta (RH 9.0.93)
Comment 2 Ngo Than 2003-07-30 09:31:02 EDT
Hm, it's a syntax bug in kernel config file.
With this patch, it should fix this problem. next kernel rebuild should have
this fix.


--- drivers/net/wan/Config.in.orig      2003-07-30 15:19:32.000000000 +0200
+++ drivers/net/wan/Config.in   2003-07-30 15:19:19.000000000 +0200
@@ -80,8 +80,7 @@
       if [ "$CONFIG_PCI" != "n" ]; then
        dep_tristate '    Cyclades-PC300 support (RS-232/V.35, X.21, T1/E1
boards)' CONFIG_PC300 $CONFIG_HDLC
        if [ "$CONFIG_PC300" != "n" ]; then
-               if ["$CONFIG_PPP" != "n" -a "$CONFIG_PPP_MULTLINK" != "n" -a
"$CONFIG_PPP_SYNCTTY" != "n" -a "$CONFIG_HDLC_PPP" = "y"];
-               then
+               if [ "$CONFIG_PPP" != "n" -a "$CONFIG_PPP_MULTLINK" != "n" -a
"$CONFIG_PPP_SYNCTTY" != "n" -a "$CONFIG_HDLC_PPP" = "y" ]; then
                        bool '      Cyclades-PC300 MLPPP support' CONFIG_PC300_MLPPP
                else
                        comment '     Cyclades-PC300 MLPPP support is disabled.
You have to enable PPP, PPP_MULTILINK'
Comment 3 Elton Woo 2003-07-30 13:26:51 EDT
I'm no programmer, but I suspected something like that. Glad to have found this.
... one less bug for your RH guys! ;-)

Note You need to log in before you can comment on or make changes to this bug.