Bug 101078 - selecting "install everything with Severn causes hard failure in installation
Summary: selecting "install everything with Severn causes hard failure in installation
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-28 22:28 UTC by Elton Woo
Modified: 2015-01-04 22:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 20:16:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elton Woo 2003-07-28 22:28:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Installation failed several times either with kernel oopses or
hard lockups of system (CPU= AMD Athlon Thunderbird, 1.0G).
First install: selecting Personal Desktop went smoothly.
Subesequent installs, selecting Workstation (select applications)
or Workstation (default applications), result in system rebooting
with failure of initscripts, *OR* installer complaining that

"/dev/hda was not formatted (!!!), please reboot system"

Sixth or seventh attempt to install: select "Install Everything".
approximately 4/5ths of installation procedure is done (formatting,
selection of components, installation of software), when installer
complains that there is "not sufficient space on /dev/hda *or*
your (install) media may be corrupted.

NOTE: On at least three of these occasions, including my first install, I took
the time to verify all three CD's before proceeding.
Also there are no other OSes on the disk (20 Mb all devoted to Red
Hat linux). I *did* opt for: "delete all partitions" or "delete all
linux partitions".

(I have only tried installing "Everything" *once*, but FWIW, I am
entering the Reproducibility as "every time", as I suspect (have
a gut feeling) that the problem *is* consistent.

Version-Release number of selected component (if applicable):
default version with Severn beta 1 (RH 9.0.93)

How reproducible:
Always

Steps to Reproduce:
1. Start Severn Beta installer.
2. Select New Installation / Workstation
3. Option: "Install Everything"
    

Actual Results:  Installation fails after approximately 70% completion, claiming
either
lack of disk space or possible failure of media.

Expected Results:  Installation should proceed as there is ample room on disk
(20 Gb), 
including space for necessary temp files.

Additional info:

Suspect this might be related to kernel oopses and AMD CPU's as per
comment from Bill Nottingham in reply to subject titled:
Masive kernel oopses with Taroon beta 1, posted by Tom Georgoulias in
today's (28 Jul.) discussions.

Comment 1 Bill Nottingham 2003-07-29 01:57:58 UTC
No, it's *probably* not related to the taroon thing; there's no athlon-specific
optimizations in the BOOT kernel, as far as I know. It does sound like a kernel
issue, however.

Comment 2 Dave Jones 2003-08-08 20:54:26 UTC
"(20 Mb all devoted to Red Hat linux)."
- I hope you meant Gb there 8-)

When it claims its out of disk space, can you hit ctrl-alt-f2 and type df and
check ?

Likewise, do 'fdisk /dev/hda' and tell us what the output of 'p' looks like

If these look sensible, this is an installer bug, not a kernel bug.
(Or possibly bad hardware).

Comment 3 Elton Woo 2003-08-08 22:37:15 UTC
The HD *is* 20 Gb, so it's totally used for Severn. Should I try a "full" install 
again? I now have a lot of things configured, so it would take some time to 
backup  
 
"Likewise, do 'fdisk /dev/hda' and tell us what the output of 'p' looks like 
 
If these look sensible, this is an installer bug, not a kernel bug.and do another 
install. "   I guess this should only be done during installation, or would that 
give any useful information *now* on the present "stable" system? 

Comment 4 Elton Woo 2003-09-04 16:48:33 UTC
I have been able to confirm that the problem is *consistent*. I've recently done
a pristine install (after several tries, I chose "Custom"). Installing all
packages STILL fails, and here is the point where it sticks:

"There is an error installing redhat-logos-1.1.14-1. This can indicate media
failure, lack of disk space and / or hardware problems. This is a fatal error 
and ....".

Since I dedicate the entire 20Gb disk to the install (including temps), this]
would indicate a problem either with anaconda, or one of the install scripts,IMHO.

My current install is not "all packages", but I now note that: 
in the KDE Control Center (Country / Region and language) a "question-mark"
icon appears instead of the country flag (Canada).
In the section, Appearance --> Icons --> Advanced, the default icons in
for Desktop Filemananager (Default/Active/Disabled) are not the ones
I recall seeing previously, but the "paper sheet with rocket" icon.

I would surmise that this relates to the problem with installing the
redhat-logos package? After recent updates from rawhide (to Sep. 03),
these are the versions now on my system:
redhat-logos-1.1.14-1
redhat-artwork-0.81-1
redhat-menus-0.39-2
kdegraphics-3.1.3-3
kdeartwork-3.1.3-2

Comment 5 Elton Woo 2003-10-17 17:49:46 UTC
Apparently fixed with Fedora Core Test3. I did *one* "Install everything" and it
was done without any problems.

Comment 6 Bill Nottingham 2003-10-21 20:16:53 UTC
Ok, closing as working in rawhide.


Note You need to log in before you can comment on or make changes to this bug.