Bug 101080 - using software installer or rpm -i from a console fails (intermittently)
using software installer or rpm -i from a console fails (intermittently)
Status: CLOSED DUPLICATE of bug 100445
Product: Red Hat Linux Beta
Classification: Retired
Component: rpm (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-28 18:54 EDT by Elton Woo
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2003-07-28 18:54:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Having installed Severn, I found that I needed some other components.
The software installer requested Disk 2 (or Disk 3, as was the case),
but the same dialog does not go away (even though there is the *correct*
disk in the drive).

Starting the install of the rpm by clicking on the icon in the /cdrom
folder, and either the install dialog starts up, or nothing happens.
There is some hard disk activity (indicated by the hd light), and the 
cd drive light flashes breifly. Other attempts: place disk in drive,
and allow rpm to close the correct drive. 

I have /dev/hdc alias cdrom1= cdwriter,
and /dev/hdd alias cdrom= DVD reader.

Copying the rpm to hard disk, and doing rpm -ivh from a console command,
and the procedure apparently hangs, as I do not get returned to my root prompt.
Attempted workaround: "forget permissions" by clicking
on the keys in the Gnome panel, and re-entering root pasword when 
clicking on rpm icon.

Sometimes this works, sometimes not.

Version-Release number of selected component (if applicable):
rpm-4.2.1-0.11

How reproducible:
Sometimes

Steps to Reproduce:
1. Start software installer / or click on rpm icon in folder /or invoke
rpm -i from a console prompt.
2. Install procedure starts *or*
3. Install procedure does NOT start.
    

Actual Results:  Install procedure starts but dialog does not disappear, or root
prompt is not returned in console mode.

Expected Results:  rpm package and /or dependencies should be installed normally.
In console mode, this should return user to the root prompt.

Additional info:

CPU: AMD Athlon  Severn beta1 (RH 9.0.93)
System memory: 512Mb (PC-100 RAM).
Video subsystem: 3DLabs nVidia card (32 Mb),
using "nv" drivers. (Nvidia drivers fail to compile
module for the present kernel).

kernel-2.4.21-20.1.2024.2.1.nptl
kernel-pcmcia-cs-3.1.31-13
kernel-utils-2.4-8.31
Comment 1 Jeff Johnson 2003-07-29 08:48:52 EDT
Can you supply details on "sometimes this works"?

Otherwise I have little hope of reproducing.

You might try rm -f /var/lib/rpm/__db* to remove locks.
Comment 2 Elton Woo 2003-07-29 15:14:11 EDT
actually, it only worked twice, other times, I cannot install *anything* ...
INCLUDING loading a cd with autorun. Using this latter option, the dialog pops
up, then says "checking system for installed packages...", then it abends. I'll
try seeing if it's stale locks as suggested, and report back. 
Comment 3 Elton Woo 2003-07-29 15:56:26 EDT
logged in to a root console, and watch this --->
[root@dhcp-133-74 root]# ls /var/lib/rpm/
Basenames     __db.003  Installtid   Provideversion  Sha1header
Conflictname  Dirnames  Name         Pubkeys         Sigmd5
__db.001      Filemd5s  Packages     Requirename     Triggername
__db.002      Group     Providename  Requireversion
[root@dhcp-133-74 root]# rm -f /var/lib/rpm/_db*
[root@dhcp-133-74 root]# ls /var/lib/rpm/
Basenames     __db.003  Installtid   Provideversion  Sha1header
Conflictname  Dirnames  Name         Pubkeys         Sigmd5
__db.001      Filemd5s  Packages     Requirename     Triggername
__db.002      Group     Providename  Requireversion
[root@dhcp-133-74 root]#

... looks like the stale locks aren't deleted, even though I *am*
su.
Comment 4 Elton Woo 2003-07-29 16:00:44 EDT
even going directly into the directory and trying to delete the file
*without* using wildcards, and the stale locks *aren't* removed --->

]# cd /var/lib/rpm
[root@dhcp-133-74 rpm]# ls
Basenames     __db.003  Installtid   Provideversion  Sha1header
Conflictname  Dirnames  Name         Pubkeys         Sigmd5
__db.001      Filemd5s  Packages     Requirename     Triggername
__db.002      Group     Providename  Requireversion
[root@dhcp-133-74 rpm]# rm -f _db.*
[root@dhcp-133-74 rpm]# ls
Basenames     __db.003  Installtid   Provideversion  Sha1header
Conflictname  Dirnames  Name         Pubkeys         Sigmd5
__db.001      Filemd5s  Packages     Requirename     Triggername
__db.002      Group     Providename  Requireversion
[root@dhcp-133-74 rpm]# rm -f _db.001
[root@dhcp-133-74 rpm]# ls
Basenames     __db.003  Installtid   Provideversion  Sha1header
Conflictname  Dirnames  Name         Pubkeys         Sigmd5
__db.001      Filemd5s  Packages     Requirename     Triggername
__db.002      Group     Providename  Requireversion
Comment 5 Elton Woo 2003-07-29 16:03:48 EDT
The only thing "different" WRT installing the beta, was that I chose "high" 
security, rather than the default "medium" security level, but I should still
be able to delete files as "su" shouldn't I?
Comment 6 Michael Young 2003-07-29 17:13:03 EDT
There is another possible explanation, that a running process is recreating the
lock files as soon as you delete them. Make sure there are no live rpm etc.
processes running first.
Comment 7 Elton Woo 2003-07-29 23:06:48 EDT
Good point. I am quite sure that there was no other rpm process running. In
fact, as I am typing this, I tried again. I'm *positive* that there is _at this
very moment_ NO rpm process running, since the machine was shut down (and
powered off), until I returned home from the gym a while ago. I still cannot
remove those stale
locks. FWIW, I login to the console with "su -" .

An attempt as root, without the root path gives me the same result:
]$ su
Password:
[root@dhcp-133-74 abe]# cd /var/lib/rpm
[root@dhcp-133-74 rpm]# rm -f _db.*
[root@dhcp-133-74 rpm]# ls
Basenames     __db.003  Installtid   Provideversion  Sha1header
Conflictname  Dirnames  Name         Pubkeys         Sigmd5
__db.001      Filemd5s  Packages     Requirename     Triggername
__db.002      Group     Providename  Requireversion
[root@dhcp-133-74 rpm]#
Comment 8 Michael Young 2003-07-30 03:35:19 EDT
You are trying to remove __db* (2 underscores) and not _db* as your post suggests?
Comment 9 Elton Woo 2003-07-30 13:14:52 EDT
Bingo! I *was* trying with *one* underscore instead of *two*. NOW, I am
able to delete those stale locks. NOTE: on my screen (1024 x 768), it's a bit
difficult to diffrentiate, since there is no visible space between the two
underscores.

Now to try rpm again....
Comment 10 Elton Woo 2003-07-30 14:11:00 EDT
I tried installing via automount (Disk 1) again. 
Place disk in my DVD drive /dev/hdd alias /mnt/cdrom
The dialog abends "checking system status..." (*blooey*!!!). 
When I go to a root console I see the same three locked files 
have been recreated: __001.db,__002.db, and __003.db. 

I delete them --->
  root]# ls /var/lib/rpm
Basenames     __db.003  Installtid   Provideversion  Sha1header
Conflictname  Dirnames  Name         Pubkeys         Sigmd5
__db.001      Filemd5s  Packages     Requirename     Triggername
__db.002      Group     Providename  Requireversion
[root@dhcp-133-74 root]# rm -f /var/lib/rpm/__db.*
[root@dhcp-133-74 root]# ls /var/lib/rpm
Basenames     Group       Providename     Requireversion
Conflictname  Installtid  Provideversion  Sha1header
Dirnames      Name        Pubkeys         Sigmd5
Filemd5s      Packages    Requirename     Triggername
[root@dhcp-133-74 root]#

... and try with a different drive, my cdwriter (/dev/hdc alias /mnt/cdrom1). 

SAME result.

QED: the problem is reproducible and consistent.
Comment 11 Elton Woo 2003-07-30 14:19:13 EDT
As a test, I mounted Disk 2, and clicked on the taipei fonts package, which
installed without any problems. I guess the problem lies with autorun and rpm?
Also, only Disk 1 will load as autorun. 
Comment 12 Asa Dotzler 2003-07-31 03:35:51 EDT
Is this the same problem as described in bug 100445? The first paragraph of
comment #1 sounds similar.
Comment 13 Elton Woo 2003-07-31 15:35:25 EDT
Yes. I also encounter that problem (as in bug 100445). I insert a CD and I say
"yes" to autorun, then select a package to install. The installer then asks me
to insert (say) Disk 2 (which I place in my other drive) 

e.g. autorun from /dev/cdrom1 (cdwriter), and insert the needed disk in 
/dev/cdrom (DVD drive).
The dialog will keep popping up: "please insert Disk 2", I click OK, and there
might be a slight flicker of the drive light. The dialog comes up several times,
and eventually after several "OK's", it disappears _without any error message_.
Comment 14 Jeff Johnson 2003-08-19 11:57:58 EDT

*** This bug has been marked as a duplicate of 100445 ***
Comment 15 Red Hat Bugzilla 2006-02-21 13:57:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.