Bug 100445 - redhat-config-packages keeps asking for disc #x (package installation impossible)
Summary: redhat-config-packages keeps asking for disc #x (package installation impossi...
Status: CLOSED DUPLICATE of bug 105767
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-packages (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 100459 100961 101080 101535 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-22 13:51 UTC by Stephane Jourdan
Modified: 2006-02-21 18:57 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephane Jourdan 2003-07-22 13:51:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030619

Description of problem:
Whatever I try to install via the redhat-config-packages interface, it keeps
asking me for the disc #x (x = corresponding required disk).
Wether I insert disc #1, #2 or #3, it keeps asking for it, without any error
message. 

When I click 'cancel', the app shutdown without any trace or whatever.

It's the same problem for *any* selected package here.

Problem seen on a clean install, fr_FR.UTF-8 language.
The same with a similar clean install, with default en_US.UTF-8 install.

It doesn't seem to check the availibility of the CD-Rom, or has a wrong database
in it ?

Version-Release number of selected component (if applicable):
redhat-config-packages-1.9.1-1

How reproducible:
Always

Steps to Reproduce:
1.launch redhat-config-packages
2.select a package to install
3.look how it keep asking the CD #x
    

Additional info:

Comment 1 Jeremy Katz 2003-07-22 17:30:58 UTC
*** Bug 100459 has been marked as a duplicate of this bug. ***

Comment 2 David Lawrence 2003-07-22 19:19:40 UTC
Verified with Cambridge-9.0.93.0. Cancel will exit entire program instead of
taking you back to the main interface.

Comment 3 Alexander M. Turek 2003-07-24 20:33:42 UTC
I also encounter this bug with Red Hat Severn.
After clicking cancel, the program shuts down as described above. Afterwards, I 
cannot access the CD-ROM's file system untill I mount it again.

I can repeat that as often as I want: the CD gets somehow unmounted everytime I 
try to install packages using this GUI.

Comment 4 Scott Newton 2003-07-27 08:00:46 UTC
This also seems to occur when attempting to install packages directly from the
cd using nautilus.  Any package that has a dependency causes the installer to
crash and immediately unmount the cd. Packages without dependencies install
without problems.

Comment 5 Bill Nottingham 2003-07-28 21:28:28 UTC
*** Bug 100961 has been marked as a duplicate of this bug. ***

Comment 6 Elton Woo 2003-07-31 19:39:11 UTC
I can concur that any installation from autorun _which requires a dependency_
will cause a constant repetition of "insert Disk #", with a *very* breif flicker
of the CD drive light, and then the dialog just disappears, without *any* error
message.

Comment 7 Bill Nottingham 2003-08-05 03:33:04 UTC
*** Bug 101535 has been marked as a duplicate of this bug. ***

Comment 8 Jeff Johnson 2003-08-19 15:58:05 UTC
*** Bug 101080 has been marked as a duplicate of this bug. ***

Comment 9 George Karabin 2003-09-27 20:38:55 UTC
I don't know if this is the same issue, or separate, but I've burned a Severn
beta 2 DVD made with Chris Kloiber's script
(ftp://people.redhat.com/ckloiber/mkdvdiso.sh). I can mount the disc, but
redhat-config-packages doesn't try to use it (on my beta 2 machine). 

Either this is the same issue, or it's a different one because
redhat-config-packages might not support DVD's yet (although I hear RHEL
supports them, so maybe it should?)

FYI, the .discinfo file looks like:

1064433227.89
Fedora Core 0.94
i386
1,2,3
RedHat/base
RedHat/RPMS
RedHat/pixmaps


Comment 10 Halldor Hafliðason 2003-10-15 15:58:04 UTC
I just installed Severn test 3 (0.95), still the same proplem, any package ( 
at all, tried them all ) makes it behave like that, this maybe doesn't matter 
to much since apt-rpm solved the problem for me, it still is annoying.
I use:
redhat-config-packages-1.2.5-2



Comment 11 Elton Woo 2003-10-15 17:14:22 UTC
The bug is still present in the latest beta (Fedora Core Test / RH 9.0.95). 
The only way to install packages is either via the console, or by opening 
a window with the CD contents and clicking on the icons. IMHO, this is not 
just a minor annoyance, but a serious lack of performance in a *necessary* 
system tool. 

Comment 12 Jeremy Katz 2003-10-20 21:44:36 UTC

*** This bug has been marked as a duplicate of 105767 ***

Comment 13 Red Hat Bugzilla 2006-02-21 18:57:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.