Bug 1010966 - xml tag "runtime" is not available in rebalance/remove-brick status xml output
xml tag "runtime" is not available in rebalance/remove-brick status xml output
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Aravinda VK
shylesh
: ZStream
Depends On:
Blocks: 1012773
  Show dependency treegraph
 
Reported: 2013-09-23 08:05 EDT by Aravinda VK
Modified: 2015-05-13 12:30 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.44.1u2rhs
Doc Type: Enhancement
Doc Text:
Enhancements were made to Rebalance and remove-brick status CLI XML outputs to include to the <runtime> xml tag.
Story Points: ---
Clone Of:
: 1012773 (view as bug list)
Environment:
Last Closed: 2014-02-25 02:39:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2013-09-23 08:05:28 EDT
Description of problem:
xml tag "runtime" is not available in rebalance/remove-brick status xml output

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Run gluster volume rebalance <VOLNAME> status 
2. Run gluster volume rebalance <VOLNAME> status --xml
3. Run time is available in CLI output but not in xml output

Actual results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volRebalance>
    <op>3</op>
    <nodeCount>1</nodeCount>
    <node>
      <nodeName>localhost</nodeName>
      <files>0</files>
      <size>0</size>
      <lookups>0</lookups>
      <failures>0</failures>
      <status>3</status>
      <statusStr>completed</statusStr>
    </node>
    <aggregate>
      <files>0</files>
      <size>0</size>
      <lookups>0</lookups>
      <failures>0</failures>
      <status>3</status>
      <statusStr>completed</statusStr>
    </aggregate>
  </volRebalance>
</cliOutput>


Expected results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volRebalance>
    <op>3</op>
    <nodeCount>1</nodeCount>
    <node>
      <nodeName>localhost</nodeName>
      <files>0</files>
      <size>0</size>
      <lookups>0</lookups>
      <failures>0</failures>
      <runtime>42</runtime>
      <status>3</status>
      <statusStr>completed</statusStr>
    </node>
    <aggregate>
      <files>0</files>
      <size>0</size>
      <lookups>0</lookups>
      <failures>0</failures>
      <runtime>42</runtime>
      <status>3</status>
      <statusStr>completed</statusStr>
    </aggregate>
  </volRebalance>
</cliOutput>


Additional info:
Comment 3 shylesh 2013-12-11 23:42:56 EST
Please specify the "fixed-in" version to be verified against.
Comment 4 shylesh 2013-12-16 04:15:53 EST
Now the xml output has "runtime" field, hence marking it as verified on 
3.4.0.49rhs-1.el6rhs.x86_64
 

<volRebalance>
    <task-id>39f9d80f-9837-481d-8503-e782f86c4570</task-id>
    <op>3</op>
    <nodeCount>4</nodeCount>
    <node>
      <nodeName>localhost</nodeName>
      <id>d52bf2e0-acc7-466f-9016-afebb50e97da</id>
      <files>217</files>
      <size>113770496</size>
      <lookups>830</lookups>
      <failures>83</failures>
      <skipped>35</skipped>
      <status>1</status>
      <statusStr>in progress</statusStr>
      <runtime>40.00</runtime>
    </node>
    <node>
      <nodeName>rhs-client9.lab.eng.blr.redhat.com</nodeName>
      <id>200a73a8-56f6-4f52-85db-1914c52da35a</id>
      <files>64</files>
      <size>33554432</size>
      <lookups>790</lookups>
      <failures>34</failures>
      <skipped>38</skipped>
      <status>1</status>
      <statusStr>in progress</statusStr>
      <runtime>40.00</runtime>
    </node>
    <aggregate>
      <files>281</files>
      <size>147324928</size>
      <lookups>1620</lookups>
      <failures>117</failures>
      <skipped>73</skipped>
      <status>1</status>
      <statusStr>in progress</statusStr>
      <runtime>40.00</runtime>
    </aggregate>
  </volRebalance>
</cliOutput>
Comment 5 Pavithra 2014-01-07 04:35:34 EST
Can you please review the doc text for technical accuracy?
Comment 6 Aravinda VK 2014-01-07 04:54:17 EST
Doc Text looks good to me.
Comment 8 errata-xmlrpc 2014-02-25 02:39:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.