Bug 1012773 - xml tag "runtime" is not available in rebalance/remove-brick status xml output
xml tag "runtime" is not available in rebalance/remove-brick status xml output
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Aravinda VK
:
Depends On: 1010966
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 02:20 EDT by Aravinda VK
Modified: 2014-04-17 09:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1010966
Environment:
Last Closed: 2014-04-17 09:14:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-27 06:22:19 EDT
REVIEW: http://review.gluster.org/5997 (cli: runtime in xml output of rebalance/remove-brick status) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 2 Anand Avati 2013-09-27 06:24:55 EDT
REVIEW: http://review.gluster.org/5997 (cli: runtime in xml output of rebalance/remove-brick status) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 3 Anand Avati 2013-09-30 05:34:53 EDT
REVIEW: http://review.gluster.org/5997 (cli: runtime in xml output of rebalance/remove-brick status) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 4 Anand Avati 2013-09-30 07:43:47 EDT
REVIEW: http://review.gluster.org/5997 (cli: runtime in xml output of rebalance/remove-brick status) posted (#5) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 5 Anand Avati 2013-10-04 00:12:44 EDT
COMMIT: http://review.gluster.org/5997 committed in master by Anand Avati (avati@redhat.com) 
------
commit 7dba6f9b556288a95d6ca7e9c3222d14cae3def5
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Sep 24 12:41:30 2013 +0530

    cli: runtime in xml output of rebalance/remove-brick status
    
    "runtime in secs" is available in the CLI output of
    rebalance status and remove-brick status, but not available
    in xml output when --xml is passed.
    
    runtime in aggregate section will be max of all nodes runtimes.
    
    Example output:
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volRebalance>
        <op>3</op>
        <nodeCount>1</nodeCount>
        <node>
          <nodeName>localhost</nodeName>
          <files>0</files>
          <size>0</size>
          <lookups>0</lookups>
          <failures>0</failures>
          <skipped>0</skipped>
          <runtime>1.00</runtime>
          <status>3</status>
          <statusStr>completed</statusStr>
        </node>
        <aggregate>
          <files>0</files>
          <size>0</size>
          <lookups>0</lookups>
          <failures>0</failures>
          <skipped>0</skipped>
          <runtime>1.00</runtime>
          <status>3</status>
          <statusStr>completed</statusStr>
        </aggregate>
      </volRebalance>
    </cliOutput>
    
    BUG: 1012773
    Change-Id: I8deaba08922a53cd2d3b411e097a7b3cf591b127
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/5997
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Anand Avati 2013-10-22 04:31:58 EDT
REVIEW: http://review.gluster.org/6118 (cli: runtime in xml output of rebalance/remove-brick status) posted (#1) for review on release-3.4 by Aravinda VK (avishwan@redhat.com)
Comment 7 Anand Avati 2013-10-24 07:06:52 EDT
COMMIT: http://review.gluster.org/6118 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 45d6c6ba540beaaab2fd9d2703ef8b2ce0da0454
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Oct 22 14:00:20 2013 +0530

    cli: runtime in xml output of rebalance/remove-brick status
    
    "runtime in secs" is available in the CLI output of
    rebalance status and remove-brick status, but not available
    in xml output when --xml is passed.
    
    runtime in aggregate section will be max of all nodes runtimes.
    
    Example output:
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volRebalance>
        <op>3</op>
        <nodeCount>1</nodeCount>
        <node>
          <nodeName>localhost</nodeName>
          <files>0</files>
          <size>0</size>
          <lookups>0</lookups>
          <failures>0</failures>
          <skipped>0</skipped>
          <runtime>1.00</runtime>
          <status>3</status>
          <statusStr>completed</statusStr>
        </node>
        <aggregate>
          <files>0</files>
          <size>0</size>
          <lookups>0</lookups>
          <failures>0</failures>
          <skipped>0</skipped>
          <runtime>1.00</runtime>
          <status>3</status>
          <statusStr>completed</statusStr>
        </aggregate>
      </volRebalance>
    </cliOutput>
    
    BUG: 1012773
    Change-Id: I6de59d4ed03983b6ffc014d6a331251cf635a690
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/5997
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/6118
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 8 Niels de Vos 2014-04-17 09:14:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.