Bug 101123 - XFree86 continually consumes system memory and swap...
XFree86 continually consumes system memory and swap...
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-29 10:28 EDT by Michael Lee Yohe
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-24 21:24:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2003-07-29 10:28:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030722 Galeon/1.3.7

Description of problem:
My system has been up for nearly a week now.  Every morning when I sit down at
the workstation - everything is crawling (in terms of performance).  The only
thing that is running the whole time is a screensaver.  I have 768M physical,
1GB swap.  My video card is an ATI Radeon 7500 (32M).

I am not running any BS ATI drivers - just plain ol' XFree86.

Upon checking top for processes that are consuming large amounts of memory (even
though its accuracy is questionable):

1259 root      15   0  564M 154M  8228 S     2.6 20.4 579:18 X

09:25:09  up 6 days, 22:25,  8 users,  load average: 0.08, 0.73, 0.99

        total:    used:    free:  shared: buffers:  cached:
Mem:  790355968 775991296 14364672        0 10113024 419852288
Swap: 1077501952 553009152 524492800
MemTotal:       771832 kB
MemFree:         14028 kB
MemShared:           0 kB
Buffers:          9876 kB
Cached:         402708 kB
SwapCached:       7304 kB
Active:         489528 kB
ActiveAnon:     272536 kB
ActiveCache:    216992 kB
Inact_dirty:     96224 kB
Inact_laundry:   97204 kB
Inact_clean:     12504 kB
Inact_target:   139092 kB
HighTotal:           0 kB
HighFree:            0 kB
LowTotal:       771832 kB
LowFree:         14028 kB
SwapTotal:     1052248 kB
SwapFree:       512200 kB

154M RSS and 564M Virtual - it's much larger than when X first starts up (about
50M RSS and 100M Virtual).  If I kill the X server and restart - the swap
partition is emptied and performance is restored.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-15

How reproducible:
Always

Steps to Reproduce:
1. see description
    

Actual Results:  XFree86 gets fat and happy.

Expected Results:  XFree86 should probably consume more memory than when it was
first started.  However, it should not consume 500-600M of total virtual memory.

Additional info:
Comment 1 Michael Lee Yohe 2003-07-29 10:50:30 EDT
My error: restarting X consumes _much_ less memory.

31398 root      15   0 67460  16M  6900 S     0.4  2.2   0:07 X

I have Galeon 1.3.7 open.  Evolution 1.4.3.  And a few terminals.

I just noticed that revision 18 (XFree86) in Rawhide fixes some memory leak
problems.  Would this be related?
Comment 2 Michael Lee Yohe 2003-07-29 12:10:20 EDT
My bug might be related to Bug 90035 (I am using animated cursors with my X
session).
Comment 3 Mike A. Harris 2003-08-01 06:13:27 EDT
Unlikely the memory leaks fixed in rawhide are affecting you.  They are small
almost irrelevant leaks which I added fixes for just for completeness.

X resources are stored in the X server, which means if applications leak X
resources, the X server's memory usage will increase.  That's not a bug in
the X server, but a bug in the application.  You need to determine which
application is causing this to happen, and then file bug reports against
that application.  (assuming this is the case, which it almost always is)

Note that screensavers can consume gobs of memory and keep your CPU's running
very busily, even if you're switched away from X.  A leak in a screensaver
also can appear as X increasing in size.

You'll need to narrow the problem down to a specific easily reproduceable
minimal test case in order for me to investigate further.  The likelyhood
though is that you'll find it is a screensaver or other application
pixmap leaking.
Comment 4 Mike A. Harris 2003-08-01 06:19:54 EDT
Oh, one more thing...  Try disabling the color mouse cursor themes entirely
to see if that affects your problem or not.  If it does, then it might very
well be the same as the bug report you refered to above.

Attach your X config file and log to the report also please.

Thanks
Comment 5 Mike A. Harris 2003-08-24 21:24:50 EDT
Lack of response, so closing as WORKSFORME as I do not experience this problem.

Note You need to log in before you can comment on or make changes to this bug.